5

I am trying to fix the wifi in my Intel NUC. I have the Intel(R) Dual Band Wireless AC 7265, REV=0x210. The driver is trying to load 'iwlwifi-7265D-24.ucode` but according to dmesg, that fails with error -2 (see below).

System information:

$ uname -a
Linux britt-desktop 4.8.0-27-generic #29-Ubuntu SMP Thu Oct 20 21:03:13 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

$ dmesg | grep 7265D
[   14.578598] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-24.ucode failed with error -2
[   14.578612] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-23.ucode failed with error -2



$ modinfo iwlwifi | grep iwlwifi
filename:       /lib/modules/4.8.0-27-generic/kernel/drivers/net/wireless/intel/iwlwifi/iwlwifi.ko
firmware:       iwlwifi-7265D-24.ucode

Any idea how to get the correct firmware to load? Thank you

EDIT:

I found a copy of iwlwifi-7265D-24.ucode and moved it to /lib/firmware. The errors are gone, but my wifi performance is still very low (~1/10th what the other older machines on the network are getting).

EDIT:

I have a ASUS RT-AC68W wireless router and I am using the 5GHz band. After I changed the wireless mode to N/AC mixed (it was on Auto), the download speeds went back up to >100Mbps. I'll keep an eye on it, but this may have fixed it. I also and using firmware iwlwifi-7265D-22.ucode for now as 24 and 23 are not in the directories.

sudo wget https://github.com/OpenELEC/iwlwifi-firmware/raw/master/firmware/iwlwifi-7265D-22.ucode
  • I'm getting the same error. My wifi freezes up randomly and I haven't been able to figure it out. I was hoping a firmware upgrade would fix it but apparently it's not happening. – aNoble Nov 5 '16 at 2:43
  • what is the output of dmesg | grep iwl? I think I solved my issue by finding iwlwifi-7265D-24.ucode and adding it to /lib/firmware. It wasn't on intel's page though. – Britt Nov 5 '16 at 12:13
  • I have the same error too on Ubuntu 16.10 (update from 16.04) on an ASUS UX305 with Intel 7265D wifi card.. Where did you find the missing ucode files? – louloulepou Nov 5 '16 at 12:58
  • Here's a gist of my dmesg output: gist.github.com/adamcrown/4bd9481d4f8039d9aedce06d75948064 I'm guessing the real problem is Microcode SW error detected. My issue seems to be only a problem with my router. So I may just take the easy way out and get a new one. – aNoble Nov 5 '16 at 15:09
  • I searched google for iwlwifi-7265D-24.ucode and moved that the /lib/firmware – Britt Nov 5 '16 at 16:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.