2

I've got a Pascal nvidia card that Ubuntu doesn't understand, and instead of automatically booting into a low graphics mode it just blanks the screen. I could install Ubuntu by editing boot parameters and using nomodeset but I can't do that once it's installed. Holding down right or left shift does nothing. Is there a way I can boot into Ubuntu?

  • 2
    You could edit the GRUB parameters on the installation from the Live Environment. That'll make it so you can set a timeout. – TheWanderer Nov 3 '16 at 21:58
  • Did you try disable UEFI boot mode in BIOS before installing and use normal legacy boot? It worked for me. – BlueManCZ Nov 3 '16 at 22:27
  • @BlueManCZ Not a good suggestion. 2 reasons: First, UEFI mode should be preferred whenever available (unless when dual booting and the first OS has been installed in Legacy); second, your suggestion implies that the OP has to reinstall. – user589808 Nov 4 '16 at 5:00
  • @CelticWarrior Ok, but how do you explain that I always saw "low graphics warning" until I install new system in Legacy? – BlueManCZ Nov 4 '16 at 12:09
  • @BlueManCZ I was able to get it working by adjusting the grub timeout without having to use legacy boot or reinstalling. UEFI works fine for the most part, I just couldn't use the shift buttons to interrupt grub. – waspinator Nov 6 '16 at 18:08
0

You can use the boot repair tool to reinstall grub with a menu delay. This will allow you to add the nomodeset option to your kernel by pressing 'e'.

https://help.ubuntu.com/community/Boot-Repair

Once booted, enable the nvidia driver in the 'additional drivers' application and reboot the computer, this time without changing the boot settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.