1

I am unable to select/install gnome-shell extensions when visiting https://extensions.gnome.org/ [filter settings: 'Compatible with: Current version'] as described in the FAQ section. I also searched for related posts (in this Forum), but could not find helpful information - although several people seem to be affected by similar issues.

  • what first comes to the eye when visiting o.m. domain, all application icons and threads appear in a pale (i.e. faded) color
  • when selecting either of these applications, a toggle (i.e. ON/OFF switch) is missing; no pop-up/red banner is shown, since the gnome-shell integration plugin is already activated
  • remarkably, reviews as well are not loading (i.e. seem to continue to load forever)
  • the 'installed extensions' tab [https://extensions.gnome.org/local/] is accessible, but empty

The system/setup I am using:

  • Ubuntu (Gnome) 16.04.1 LTS 64-bit
  • Kernel vers.: 4.4.0-45
  • GNOME Shell 3.18.5
  • gnome-tweak-tool is installed
  • Firefox vers.: 49.0.2
    • the gnome-shell integration plugin is enabled ['always activated'; confirmed in 'about:plugins']
    • 'click_to_play' settings disabled(i.e. set to false) [in 'about:config']

Just to exclude putative conflicts, here is my output of apparmor_status | grep firefox

/usr/lib/firefox/firefox{,*[^s][^h]}
/usr/lib/firefox/firefox{,*[^s][^h]}//browser_java
/usr/lib/firefox/firefox{,*[^s][^h]}//browser_openjdk
/usr/lib/firefox/firefox{,*[^s][^h]}//lsb_release
/usr/lib/firefox/firefox{,*[^s][^h]}//sanitized_helper
/usr/lib/firefox/firefox{,*[^s][^h]} (2937) 
/usr/lib/firefox/firefox{,*[^s][^h]} (3694) 

I tried repeatedly to reload the pages/restart Firefox/restart the gnome-shell/reboot the system. No change so far.

Would highly appreciate any ideas what might cause the issue.

  • Do you have any browser extensions installed, especially ad blockers? – PyGeek03 Nov 3 '16 at 15:52
  • As for Firefox browser extensions I am using the following: Adblock Plus [disabled on extensions.gnome.org ] and NoScript [allowing everything on extensions.gnome.org/]. - I tried to completely disable both - without any effects. – brunuser Nov 3 '16 at 16:44
  • ...just for the sake of completeness: Restarting Firefox in Safe-Mode does not solve the issue either. – brunuser Nov 3 '16 at 19:16
1

Update: I circumvented the issue by installing the Epiphany browser via sudo apt-get install epiphany. Using this browser I was able to install the shell extensions of interest using the web-integrated toggle (all above-mentioned irregularities were unobserved).

Since the extensions were now locally saved in ...

~/.local/share/gnome-shell/extensions

... I then removed Epiphany and dependent files: sudo apt-get remove epiphany && sudo apt-get autoremove [I was reluctant to use purge command.].

Making a blind guess there might have been a conflict between (some) Firefox (default) configurations and the communication between the script on https://extensions.gnome.org/local/ with the gnome-shell?


PS: In case anyone has issues installing the gnome-shell extension 'System Monitor' on Ubuntu (Gnome) 16.04, i.e. a silent fail of the installation using the toggle co-occurrent with the switch going back into 'OFF' position after page-refresh, You might need to install libgtop2-10 & gir1.2-gtop-2.0code. The extension is dependent on those, which seem not to be included by default in the 16.04 LTS installation. Apparently the missing dependencies are recognized and the installation from the web-interface fails/is aborted for this very reason. Unfortunately You are not dclearly informed about this error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.