When I open the connection setting then I press

"wifi key" , airplane mode switches on and off. When I switch the wifi toggle on wireless network, it turns off again, I mean I am not able to turn on the wifi.

farisul@farisul-notebook:~$ lspci -knn | grep Net -A2; rfkill list
03:00.0 Network controller [0280]: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter [168c:0036] (rev 01)
    DeviceName: Qualcomm Atheros QCA9565 802.11b/g/n WiFi
    Subsystem: Hewlett-Packard Company QCA9565 / AR9565 Wireless Network Adapter [103c:217f]
    Kernel driver in use: ath9k
    Kernel modules: ath9k
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: hp-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
2: hp-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: yes
3: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

How ca I fix it?

  • Please edit your question and add output of lspci -knn | grep Net -A2; rfkill list terminal command. – Pilot6 Nov 3 '16 at 13:44
  • @Pilot6 Thats it, I hope do it right – Ben Hebat Nov 3 '16 at 14:03
  • see askubuntu.com/a/708103/15811 1st 4 lines of the answer – Rinzwind Nov 3 '16 at 14:24
  • @Rinzwind I try type the command and then "404 http not found" – Ben Hebat Nov 3 '16 at 14:31

I had the same problem with a Toshiba Satellite several times, and solved it doing either:

  1. If you have a dual boot with Windows, and you disable your wifi in Windows, in my case it also blocked the wifi for Ubuntu.

  2. Sometimes the laptop just "hangs" on the hard-blocking and the only way is to remove your laptop battery, which resets the BIOS (my laptop does not have a cmos battery).


First go into BIOS and reset it to defaults. If that does not help, then run in terminal

sudo tee /etc/modprobe.d/blacklist-hp.conf <<< "blacklist hp_wmi"

and reboot.

  • You my savior, thx very much, problem solved.... thank you thank you, god bless you – Ben Hebat Nov 3 '16 at 16:04
  • How did you solve it? By bios reset or blacklisting hp_wmi? – Pilot6 Nov 3 '16 at 16:05
  • Before see your post, I get some advice from google tell me to reset bios, I I have done it, nothing change. Then I try your suggestion (blacklisting hp_wmi, and work well... But when I press the wifi button/key bluetooth is turned on/off too, so however now I can connect to wifi – Ben Hebat Nov 3 '16 at 16:10
  • Please add your laptop model to your question to let people know where it is applicable. – Pilot6 Nov 3 '16 at 16:11

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.