1

I just installed Ubuntu 16.04 via burned CD on a new laptop (Lenovo Thinkpad) with Windows 7 installed. I chose to partition the hard drive the default way (~50/50 split) for a dual boot solution and generally accepted defaults during installation.

When I boot the machine, it goes straight to Windows. Booting from the CD indicates Ubuntu is indeed installed. I hold shift during boot but no Grub loader comes up. I've gone into the BIOS and checked for various fast boot options to disable but none really appeared (though I disabled a fast something or other for power from Intel, but that probably wasn't relevant). It loads both UEFI and Legacy and the default was to boot from Legacy first; I changed that to boot from UEFI first to no effect.

I've also tried to do the Grub2 solution: sudo apt-add-repository ppa:yannubuntu boot-repair, etc. (I did it a few times.) I get an error:

The current session is in Legacy mode. Please reboot the computer, and use this software in an EFI session. This will enable this feature. For example, use a live-USB of Boot-Repair-Disk-64bit (www.sourceforge.net/p/boot-repair-cd), after making sure your BIOS is set up to boot USB in EFI mode.

I tried following the instructions but didn't get anywhere. Is the default ISO from Ubuntu's website not 64-bit? Is there something else I should be looking at?

Thanks for any help you can provide!

  • File name of the iso I downloaded is ubuntu-16.04.1-desktop-amd64. Seems to suggest a 64 bit file. Full error message is: "The current session is in Legacy mode. Please reboot the computer, and use this software in an EFI session. This will enable this feature. For example, use a live-USB of Boot-Repair-Disk-64bit (www.sourceforge.net/p/boot-repair-cd), after making sure your BIOS is set up to boot USB in EFI mode." – Michael Nov 3 '16 at 3:04
  • 1
    The problem is the UEFI+Legacy mix up and the fact that you installed Windows 7 (Legacy) and Ubuntu (UEFI) in different modes. – user589808 Nov 3 '16 at 3:15
  • @Michael "amd64" indicates 64-bit (AMD) architecture. "i386" indicates 32-bit (Intel) architecture. – wjandrea Nov 3 '16 at 3:21
  • Could you please run Boot-Info and edit your question to include a link to its resulting info log? Thanks. – David Foerster Nov 3 '16 at 10:35
  • Please run the Boot Info Script. This will generate a file called RESULTS.txt. Post that file to a pastebin site and post the URL to your document here. This will give us more details about your configuration, which is required to base an answer on more than guesswork. – Rod Smith Nov 3 '16 at 18:24

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.