3

I have a Qualcomm Atheros QCA6174 network driver.

I am having very slow Wifi on my Linux OS but it works fine on Windows 10. When I use an ethernet cable everything works, but WiFi is slow and sometimes just doesn't connect.

Can anyone guide me on how I can fix this?

Here is some more information about my Driver:

Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 20)

Subsystem: Foxconn International, Inc. QCA6174 802.11ac Wireless Network Adapter [105b:e08e]

Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+

Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx+

Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 35
Region 0: Memory at d1400000 (64-bit, non-prefetchable) [size=2M]
Capabilities: <access denied>
Kernel driver in use: ath10k_pci
Kernel modules: ath10k_pci
  • I deleted my earlier comments to clean up the comment area, I would recommend doing the same. As for your issue, how did you initially install the driver? This can be a good starting point, because some things might not have been installed correctly. Also, is there any sort of pattern as to when it doesn't connect? Like when having a certain application open or just after a reboot, etc. Please edit this information into your post, as well. – TheOdd Nov 2 '16 at 21:11
  • There isn't a pattern. The WiFi randomly chooses to work, other times it is very slow. I did nothing to install the driver and am simply using what came with Ubuntu-minimal. – VBoi Nov 2 '16 at 21:14
  • Oh, well, that's a good starting point. I would recommend checking this out. – TheOdd Nov 2 '16 at 21:15
  • The link in the answer after the command wget leads me to a 404 error, and hence when I type the solution from the link into the terminal there is an error. – VBoi Nov 2 '16 at 21:21
  • That file seems to be missing from the mirror, but I did find the link for the most recent version on the same mirror: mirrors.kernel.org/ubuntu/pool/main/l/linux-firmware/… – TheOdd Nov 2 '16 at 21:24
1

Alright what you could do is try adding a line to your config

sudo su
echo "options ath9k nohwcrypt=1" >> /etc/modprobe.d/ath9k.conf

Then reboot your pc to see if this helped. If this did not fix your speed issue I have another trick you could use.

Force disable the 802.11n protocol. While the protocol is supposed to provide better speed with newer routers. Most modern day routers actually do not use this protocol which can cause issues.

Open the terminal and use the following command:

sudo rmmod iwlwif
sudo modprobe iwlwifi 11n_disable=1

Now try reconnecting to the net if this did not fix the issue then oh well but if it did then to make the change permanent issue these commands.

sudo su
echo "options iwlwifi 11n_disable=1" >> /etc/modprobe.d/iwlwifi.conf

Hopefully this will have fixed your issue and if not I have one last thing you could do and that is to disable ipv6 while I am not sure your provider has ipv6 support sometimes this can cause issue with certain routers and ISP's to test if this is the issue

sudo su
echo "#disable ipv6" >> /etc/sysctl.conf
echo "net.ipv6.conf.all.disable_ipv6 = 1" >> /etc/sysctl.conf
echo "net.ipv6.conf.default.disable_ipv6 = 1" >> /etc/sysctl.conf
echo "net.ipv6.conf.lo.disable_ipv6 = 1" >> /etc/sysctl.conf

For any of the above just sudo gedit 'the filename and location' such as

sudo gedit /etc/modprobe.d/ath9k.conf

Then fine the line which was added and remove it.

The second solution I provided a way to test to see if it helps before making it permanent so you wont need to do any manual edits to undo it unless you choose to do the step that makes the change permanent.

If nothing I provided helped please comment get back to me etc.

| improve this answer | |
  • Thanks for the response! Can you briefly explain what your first solution is doing? – VBoi Nov 2 '16 at 21:24
  • @AlexCooper can you add instructions to revert the changes that you are instructing the OP to make, just in case they don't work for him and so those changes aren't permanent. – TheOdd Nov 2 '16 at 21:27
  • @OwenHines added a sample line to show him how to open the the config in a text editor to remove the changes. – Alex Cooper Nov 2 '16 at 22:03
  • @vBoi the first solution is adding a config parameter for your wifi adapter that is disabling a feature which can sometimes cause issues for Atheros adapters. If none of these soultions works I will also guide you through downloading and compiling a new copy of the needed driver from wireless.kernel.org – Alex Cooper Nov 2 '16 at 22:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.