How can I completely remove all traces of Java on my system?

I already know how to install it in case I need it again.


9 Answers 9

  1. Remove all the Java related packages (Sun, Oracle, OpenJDK, IcedTea plugins, GIJ):

    dpkg-query -W -f='${binary:Package}\n' | grep -E -e '^(ia32-)?(sun|oracle)-java' -e '^openjdk-' -e '^icedtea' -e '^(default|gcj)-j(re|dk)' -e '^gcj-(.*)-j(re|dk)' -e '^java-common' | xargs sudo apt-get -y remove
    sudo apt-get -y autoremove
  2. Purge config files (careful. This command removed libsgutils2-2 and virtualbox config files too):

    dpkg -l | grep ^rc | awk '{print($2)}' | xargs sudo apt-get -y purge
  3. Remove Java config and cache directory:

    sudo bash -c 'ls -d /home/*/.java' | xargs sudo rm -rf
  4. Remove manually installed JVMs:

    sudo rm -rf /usr/lib/jvm/*
  5. Remove Java entries, if there is still any, from the alternatives:

    for g in ControlPanel java java_vm javaws jcontrol jexec keytool mozilla-javaplugin.so orbd pack200 policytool rmid rmiregistry servertool tnameserv unpack200 appletviewer apt extcheck HtmlConverter idlj jar jarsigner javac javadoc javah javap jconsole jdb jhat jinfo jmap jps jrunscript jsadebugd jstack jstat jstatd native2ascii rmic schemagen serialver wsgen wsimport xjc xulrunner-1.9-javaplugin.so; do sudo update-alternatives --remove-all $g; done
  6. Search for possible remaining Java directories:

    sudo updatedb
    sudo locate -b '\pack200'

    If the command above produces any output like /path/to/jre1.6.0_34/bin/pack200 remove the directory that is parent of bin, like this: sudo rm -rf /path/to/jre1.6.0_34.

  • 7
    Have you tested this answer? I'm reasonably certain you've got it all, but just double checking. :) Commented Sep 10, 2012 at 19:03
  • 17
    @JorgeCastro, absolutely. I built those commands one by one, then piped it all together and I ran all of them in different Java installation scenarios that I have for test purposes in some workstations at work. I really paid attention to the output of grepthat is piped to apt-get remove, I think that it covers almost all possibilities regarding installation by deb packages. Commented Sep 11, 2012 at 0:50
  • 5
    Although the presented sequence of commands works on most cases, I think my answer needs some improvements. Everybody, please, feel free to suggest changes that can improve it, like better explanation of each command or pointing out a scenario not covered by them. Commented Sep 11, 2012 at 1:11
  • 4
    +1 for the answer. I recently found a scenario where removing openjdk causes installation of other java packages. A workaround for this problem is disabling all of the repository and then execute the removal command.
    – Anwar
    Commented Sep 11, 2012 at 8:54
  • 3
    @n00b probably because there's no .java directory in your home. What was the actual error message? Commented Mar 19, 2014 at 16:34

To completely remove OpenJDK on Ubuntu 11.10 (this may or may not be sufficient on other versions of Ubuntu), run:

sudo apt-get purge openjdk-\* icedtea-\* icedtea6-\*

If you want instructions for removing the proprietary Oracle ("Sun") version of Java, then you'll have to specify how you installed it. (If you edit your question to indicate this and leave a comment to this answer, I'll try to add information about how to remove that too.)

  • 2
    I tried the above, and it completed without error on Ubuntu 11, but after I can still run java -version and get back openjdk version "11.0.3" 2019-04-16 Commented May 24, 2019 at 14:17

To uninstall Oracle Java 7, just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command below.

sudo update-alternatives --display java

To check the setup before uninstalling Java.

Next, remove symlinks

(replace the word (version)with your Java version. DO java -version to get yours. So if your version is 1.7.0_03, you would type sudo update-alternatives --remove "java" "/usr/lib/jvm/jdk1.7.0_03/bin/java")

sudo update-alternatives --remove "java" "/usr/lib/jvm/jdk<version>/bin/java"
sudo update-alternatives --remove "javac" "/usr/lib/jvm/jdk<version>/bin/javac"
sudo update-alternatives --remove "javaws" "/usr/lib/jvm/jdk<version>/bin/javaws"

verify that the symlinks were removed

java -version
javac -version
which javaws

The next 2 commands must be type excatly perfectly to avoid permanently destroying your system.

cd /usr/lib/jvm
sudo rm -rf jdk<version>

Then do

sudo update-alternatives --config java
sudo update-alternatives --config javac
sudo update-alternatives --config javaws

Then do

sudo vi  /etc/environment

Delete the line with JAVA_HOME 1

To uninstall OpenJDK (if installed). First check which OpenJDK packages are installed.

sudo dpkg --list | grep -i jdk

To remove openjdk:

sudo apt-get purge openjdk*

Uninstall OpenJDK related packages.

sudo apt-get purge icedtea-* openjdk-*

Check that all OpenJDK packages have been removed.

sudo dpkg --list | grep -i jdk


  • Could you not remove the /usr/lib/jvm folder too? As far as I know that is only used by Java.
    – njallam
    Commented Sep 8, 2012 at 17:54
  • I suppose you could, you can add that in there, or I can with your OK.
    – Mitch
    Commented Sep 8, 2012 at 17:55

You may not need to completely remove the OpenJDK to resolve your problem. Install the sun-java6 packages. Then use update-java-alternatives to switch to the Sun java packages.

If you do want to completely remove OpenJDK remove the default-jdk and/or default-jre packages. You may need to remove some java packages but most of them should be happy once you have the Sun JDK packages installed.

You may want to follow one of these cleanup tips once you are done removing packages.

  • I did the update-java-alternatives already. Should have mentioned that. I also did update-alternatives --config java. Now chrome and firefox tell me my java plugin is blocked because it's old... Commented Dec 2, 2011 at 3:13
  • Run update-java-alternatives with the --plugin option and set it back to the original value. You can mix and match defaults with this tool. The browsers installed with 11.10 may be expecting sun-java7.
    – BillThor
    Commented Dec 2, 2011 at 3:24

Try this command:

java -version

If 1.6* comes then try:

sudo apt-get autoremove openjdk-6-jre

If 1.7* comes then try:

sudo apt-get autoremove openjdk-7-jre

Assuming that you don't have jdk in your system. If you have use this command:

sudo apt-get autoremove openjdk-`<version>`-jdk

replace with the version like we did it in previous example.


easier is to use synaptic.

click tab "sections" scroll down to java. simply select each item you see with green box and mark for complete removal. repeat for all all java sections and all files.


Agreed with Eliah. "apt-get purge" command can remove those packages completely.

Assuming you have previously installed a copy of java-6-sun package, a followup will help getting rid of broken symbolic link:

sudo update-alternatives --config java

And then select a correct path which you want to link up as default Java calling path.

Then have a check on the version of Java with this command:

java -version

Just remove all files of JDK or JRE, for example it's usually installed in this location:


So remove all files resides in "java-7-oracle" folder with root permission and extract the latest JDK or JRE files in it. That's it now you would have the latest Java version Installed.

P.S. Your directory name may differ from java-7-oracle.

Reference: Official installation instruction from Oracle


With JDK 18

sudo apt-get autoremove openjdk-18-jdk

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .