6

I've been having a strange error where I get a dns_probe_finished_nxdomain error whenever I try to navigate to outlook.live.com on my ubuntu computer. It happens in firefox, chrome, and curl in both regular and private/incognito modes. I've tested it on multiple wifis and I still get the same error. I haven't tested it with Ethernet yet, but if you need me to I can. Just to make sure it wasn't a problem with my hardware, I tested it with Windows 10 on the same machine. There were no errors in that case. So I can conclude that the problem is with Ubuntu itself, probably only my particular installation.

Computer Specs:

  • Model: Lenovo G50-70
  • OS: Ubuntu 16.04 LTS
  • Wifi specs:
description: Wireless interface
product: RTL8723BE PCIe Wireless Network Adapter
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:02:00.0
logical name: wlp2s0
version: 00
serial: 38:b1:db:7c:18:bd
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=rtl8723be driverversion=4.4.0-45-generic firmware=N/A ip=10.37.164.155 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
resources: irq:19 ioport:3000(size=256) memory:c0400000-c0403fff
8

I solved this by clearing the DNS cache on my computer. I think I used this command, but I'm not 100% sure:

sudo /etc/init.d/dns-clean
1
1

I had a similar problem with my Ubuntu, even though it was working on my dual-booting Windows. What I did was to change the DNS settings from default to the DNS addresses of OpenDNS. I did this on a router level, but you should be able to also do it from within the OS.

Primary DNS Address: 208.67.222.222 Secondary DNS Address: 208.67.220.220

Router method: go in to your router settings, find DNS settings and set in the 2 addresses. OS method: Go into network applet -> edit connections -> choose your network -> IPv4 Settings -> Additional DNS servers -> 208.67.222.222, 208.67.220.220

Put the addresses in with a comma in between (Ubuntu shows the correct format) `

0

Not the answer you're looking for? Browse other questions tagged or ask your own question.