14

I'm trying to install Ubuntu 14.04 from live USB beside windows 10; but there is no grub and it boots directly to windows. I already did everything suggested in other questions but no luck. I retried the install with and without /boot partition, did the mount thing, but still no sign of grub. The last things I tried were these:

sudo grub-install --target=i386-pc --force /dev/sda7
sudo grub-install --target=i386-pc --force /dev/sda4
sudo mount /dev/sda7 /mnt
sudo grub-install --root-directory=/mnt/ --force /dev/sda
sudo mount /dev/sda4 /mnt
sudo grub-install --root-directory=/mnt/ --force /dev/sda

it shows a warning message as:

Embedding is not possible. GRUB can only be installed in this setup by using blocklists. However, blocklists are UNRELIABLE and their use is discouraged.

and says Installation is finished; but when I restart, there is still no grub. my partitions are:

sda7 --> boot

sda6 --> home

sda5 --> swap

sda4 --> /

sda2 --> C:

sda1 --> windows boot manager (efi)

8
  1. In Windows, go to the menu.
  2. Search for Command Prompt, right click on it to run it as administrator.
  3. In here, copy paste the command: bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi
  4. Restart and you’ll be welcomed by the familiar Grub screen.

This one worked for me. Source & credits to https://itsfoss.com/no-grub-windows-linux/ Abhishek Prakash

2
  • This does not work how to undo this ? Nov 28 '20 at 10:08
  • @HamendraSunthwal the commands to undo are written in the source mentioned above Nov 30 '20 at 18:58
7

You have to disable fast startup in Windows:

  1. Go to Control panel -> All control panel items -> Power options -> Choose what the powers button do
  2. Click on Change settings that are currently unavailable
  3. Uncheck Turn on fast startup
  4. Uncheck Hibernate
  5. Restart entering Bios/UEFI
  6. Move Ubuntu on top of Windows
  7. Save and restart

Now everything should work!

3
  • Thank you for the response. I already did turn off fast startup, but there is no Ubuntu option in the bios. I uninstalled Ubuntu14.04 and installed Ubunttu 16.04. After that using this in windows command worked: bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi Nov 2 '16 at 9:53
  • 1
    I can confirm that this works without any further changes in feb 2020 with windows 1909 installed (first) in UEFI mode on one SSD and Ubuntu 19.10 installed on a second SSD (My motherboard/firmware is ASRock Z68 ext3 gen3)
    – glaux
    Feb 7 '20 at 23:35
  • 1
    Can confirm this did the trick for me
    – ColinM
    Jun 4 '20 at 22:15
2

if you an a newer computer the bios may be defaulting to the windows boot manager, go to bios and make sure the ubuntu uefi is the first boot option. This should correct the problem.

1
  • 2
    I have tried that. but in the boot options list in bios menu, there is no ubuntu. It's only windows boot manager and CD-ROM and ... Nov 2 '16 at 6:24
2

In my case, I had to go into BIOS and change boot order, as GRUB was on the secondary (new) partition

1

I uninstalled Ubuntu14.04 and installed Ubunttu 16.04. After that using this in windows command worked:

bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.