0

When I type in the terminal:

sudo apt-get install "NAME OF THE PROGRAM"

there isn't any problem, but when I do:

sudo add-apt-repository ppa:"SMTHG HERE"
sudo apt-get update
sudo apt-get install "NAME OF THE PROGRAM"

I get the output:

E:Unable to locate package "NAME OF THE PROGRAM"

This has happened every time I try to install an application from a ppa.

Output of uname -a: Linux dcalderon-MS-7693 3.19.0-73-generic #81-Ubuntu SMP Tue Oct 18 16:03:37 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Specific example:

sudo add-apt-repository ppa:tualatrix/ppa
sudo apt-get update
sudo apt-get install ubuntu-tweak

How should I proceed?

  • Perhaps giving a specific example of a PPA software package that isn't installing would help us help you. Please include the exact terminal commands you've tried, in order. – Nick Weinberg Nov 1 '16 at 19:09
  • 1
    THis is a case where we need specifics. If everything's a variable, how are we supposed to know if you didn't simply add the wrong PPA? – TheWanderer Nov 1 '16 at 19:15
  • Probably the package is not compiled for your Ubuntu release... but without example of PPA and information about your ubuntu version we can only guess.. . – Rostislav Kandilarov Nov 1 '16 at 19:28
  • Also add the output of uname -a to your question. – Fabby Nov 1 '16 at 20:11
  • What's your Ubuntu release? You can find out with the output of lsb_release -a. I suspect that you're running an outdated Ubuntu release. – David Foerster Nov 2 '16 at 9:34
2

The packages that are in the ppa:tualatrix/ppa are compiled for many Ubuntu versions up to 14.04. Trusty. Probably you are running 16.04 or 16.10 and that is the reason you cannot install the ubuntu-tweak. It is not an error and probably you fail installing other packages based on outdated Ubuntu tutorials that are misleading you (and many other users as well)...

There is a good explanation about manual install or alternative tweaks at How can I install Ubuntu tweak on Ubuntu 16.04

| improve this answer | |
  • 1
    With due respect, 16.06 doesn't exist. Perhaps you meant to say 16.10 (yakkety)? Please edit your answer. – grooveplex Nov 1 '16 at 21:16
  • Already done, 10x:). – Rostislav Kandilarov Nov 1 '16 at 23:14
  • OP has kernel v3.19 while Xenial and Yakkety have (at least) v4.4 and v4.8 respectively. It's more likely that OP is still on Vivid which leads to the same fundamental issue. – David Foerster Nov 2 '16 at 9:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.