3

My problem

I do not get any sound from any of my analog connectors. HDMI output from the Radeon card is working fine when i select that in pavucontrol.

All jacks are showing (unplugged) in pavucontrol wether cable is plugged in or not.

This is not a fresh install, but i encounter the same problem when booting from a live disk.

My hardware:

  • Asus M5A99FX PRO R2.0
  • AMD Radeon 7950

I'm running Xubuntu 16.04.


Some info

You can find my alsa-info.sh output here: http://www.alsa-project.org/db/?f=6dd562654110341b541e4169680a9bff855a159d

lspci -v | grep -A7 Audio

00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) (rev 40)
Subsystem: ASUSTeK Computer Inc. SBx00 Azalia (Intel HDA)
Flags: bus master, slow devsel, latency 32, IRQ 16
Memory at feb00000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel

--
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti HDMI Audio [Radeon HD 7870 XT / 7950/7970]
Subsystem: XFX Pine Group Inc. Tahiti XT HDMI Audio [Radeon HD 7970 Series]
Flags: bus master, fast devsel, latency 0, IRQ 47
Memory at fea60000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel

cat /etc/modprobe.d/alsa-base.conf

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
#install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
#install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
#install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }

# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
#options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2

What i've tried

I've tried (among other things):

  • All the obvious stuff (headphones are working, alsamixer is not muted, etc)
  • Making sure that audio device is enabled in bios
  • Toggling front audio in bios between AC97 & HD
  • Installing realtek drivers from their site.
  • Adding "options snd-hda-intel model=auto" & other models to /etc/modprobe.d/alsa-base.conf
  • https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS
  • Disabling / enabling loopback & automute in alsamixer
  • Using multiple built-in audio profiles in pavucontrol
  • Using multiple ports in pavucontrol
  • Using one of the latest kernels to get new alsa driver
  • Reinstalling alsa & pulseaudio
  • Killing the pulse daemon and testing sound with:

    aplay -D plughw:0,0 /usr/share/sounds/alsa/Front_Center.wav

    speaker-test -c 2 -t wav

  • Renaming /etc/modprobe.d/alsa-base.conf to make alsa use defaults

  • Disabling jack detection with hdajackretask
  • Retasking rear green line out to other options with hdajackretask
  • Testing sound output from a fresh windows install (which worked...)

Pulse errors

I noticed something that i think is causing this, but i can't find any relevant solutions on the web.

Pulse is logging thousands of messages like this in debug mode.

Nov  1 17:09:44 synapse pulseaudio[2445]: [alsa-source-ALC892 Analog] alsa-source.c: Overrun!
Nov  1 17:09:46 synapse pulseaudio[2445]: message repeated 10 times: [ [alsa-source-ALC892 Analog] alsa-source.c: Overrun!]

I've been debugging this issue for 2 days now. This is the first problem with ubuntu i have not been able to solve by myself.

Any advice would be appreciated. When you need more information about my system, please ask.

  • What error is reported by your aplay test? – laugeo Nov 2 '16 at 21:13
  • @laugeo No errors are reported by aplay – Johan Schuijt Nov 3 '16 at 12:44
6

I had the same problem. The first time i did an upgrade from 14 lts to 16 and surprise, no sound. After then i do a new installation without any results by default.

The next steps work for me:

  1. Open a terminal and type alsamixer, with the card HDA ATI SB with chip Realtek ALC892, turn auto-mute to disabled.
  2. After that i'd install Pulse Audio Volume control.
  3. Open it Pulse Audio Volume Control and in Configuration tab you can see the ATI HDMI Digital Setereo and Internal Audio. Select to Internal Audio: Stereo Analog Duplex (Estéreo analógico duplex).
  4. In Pulse Audio Volume, select Ouput devices, and for Internal Analog Stereo select: analg headphones.

Important: You must have installed the ATI drivers first. D Atonaltzin

Motherboard Gigabyte GA-880GM-USB3 (realtek ALC892 audio integrated), AMD Phenom II, 4GB RAM, Ati Radeon RX460 2GB graphics card.alsamix

  • Thanks for the hints! I'm using a USB Logitech Headset and set both, the nvidia HDA and the Intel HDA to "off". No clipping, lagging anymore .. ! – lhlmgr Nov 18 '18 at 20:29
  • It's 2019 on Ubuntu 18.04 and my sound on this system config just spontaneously stopped working after a reboot. Your procedure helped me restore sound output. Thank you for taking the time to write this up. – ppetraki Jun 8 at 12:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.