2

After upgrading Ubuntu from 14.04 to 16.04, my most favourite application suddenly stopped playing music with the error message:

** Message: don't know how to handle audio/mpeg, mpegversion=(int)1, mpegaudioversion=(int)1, layer=(int)3, rate=(int)44100, channels=(int)2, parsed=(boolean)true
 pid:17764: (media plugin) processGSTEvents:273: GST error: You do not have a decoder installed to handle this file. You might need to install the necessary plugins.
 pid:17764: (media plugin) processGSTEvents:273: GST error: Internal data flow error.

Investigation shows that this codec was in gstreamer0.10-plugins-ugly, but that doesn't exist anymore in 16.04!? There is a gstreamer1.0-plugins-ugly, but this application isn't using gstreamer1.0 and doesn't look for it.

How can I get my plugins back? I will need the 'bad' plugins too.

Note that I already tried installing ubuntu-restricted-extras, but that didn't help.

2
  • I would prefer to comment with this question, but am not permitted. While trying to use the Carlo Wood solution, I get an error at this command: sudo apt-get build-dep gst-plugins-ugly1.0 E: Unable to find a source package for gst-plugins-ugly1.0 I'm not sure how to resolve this error. – Ken H Jan 3 '18 at 18:36
  • @KenH Do you have a deb-src line in your /etc/apt/sources.list ? – Carlo Wood Jan 4 '18 at 20:25
1

First I tried to port the application to gstreamer1.0, but that is IMPOSSIBLE...

In the end I got my music working again with the following:

wget http://archive.ubuntu.com/ubuntu/pool/universe/g/gst-plugins-ugly0.10/gst-plugins-ugly0.10_0.10.19-2ubuntu5.dsc
http://archive.ubuntu.com/ubuntu/pool/universe/g/gst-plugins-ugly0.10/gst-plugins-ugly0.10_0.10.19-2ubuntu5.debian.tar.gz
http://archive.ubuntu.com/ubuntu/pool/universe/g/gst-plugins-ugly0.10/gst-plugins-ugly0.10_0.10.19.orig.tar.bz2
sudo apt-get install build-essential fakeroot devscripts debhelper docbook-to-man
sudo apt-get build-dep gst-plugins-ugly1.0
dpkg-source -x gst-plugins-ugly0.10_0.10.19-2ubuntu5.dsc
cd gst-plugins-ugly0.10-0.10.19
vi debian/rules

comment out:

#ifeq (,$(findstring $(DEB_HOST_ARCH),m68k arm))
#DEB_CONFIGURE_EXTRA_FLAGS += --enable-gtk-doc
#endif

because making the docs didn't work.

vi debian/control

Remove the whole gstreamer0.10-plugins-ugly-doc Package: .. Description, otherwise if now fails to create the .deb.

DEB_HOST_MULTIARCH="$(dpkg-architecture -qDEB_HOST_MULTIARCH)" debian/rules -j 8 build-arch
fakeroot debian/rules binary
sudo dpkg -i ../gstreamer0.10-plugins-ugly_0.10.19-2ubuntu5_amd64.deb

Enjoy

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.