0

On ubuntu 16.04.
When I run lspci -nnk | grep -iA2 net I get:

01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
    Subsystem: Lenovo RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [17aa:383a]
    Kernel driver in use: r8169
    Kernel modules: r8169
02:00.0 Network controller [0280]: Qualcomm Atheros Device [168c:0042] (rev 30)
    Subsystem: Lenovo Device [17aa:4035]
    Kernel modules: ath10k_pci

$ rfkill list
0: ideapad_wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: ideapad_bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

As requested:

$ uname -a; dmesg | grep ath
Linux Yinon 4.4.0-45-generic #66-Ubuntu SMP Wed Oct 19 14:12:37 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Edditional edit:

$ sudo modprobe ath10k_pci
modprobe: ERROR: could not insert 'ath10k_pci': Required key not available
$ dmesg | grep ath
[    1.509368]  [<ffffffff81081212>] warn_slowpath_common+0x82/0xc0
[    1.509370]  [<ffffffff810812ac>] warn_slowpath_fmt+0x5c/0x80

Ethernet works good.
How can I find out what is wrong?

marked as duplicate by chili555 wireless Nov 1 '16 at 15:32

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Please add output of uname -a; dmesg | grep ath to your question. And also remove wl by sudo apt purge bcmwl-kernel-source. – Pilot6 Nov 1 '16 at 9:55
  • Added. I also removed w1, I don't know if it was supposed to resolve the problem but it didn't. – Yinon Eliraz Nov 1 '16 at 10:02
  • It is not w1, it is wl. See the @YinGroen answer. – Pilot6 Nov 1 '16 at 10:08
  • Please edit your question to add the result of the terminal commands: sudo modprobe ath10k_pci and also: dmesg | grep ath when run after the modprobe. – chili555 Nov 1 '16 at 14:15
  • I have added the commands you requested. @chili555 – Yinon Eliraz Nov 1 '16 at 15:24
1

This seems to be the general solution for 168c:0042 device issues, although it hasn't worked for me:

Update your device firmware:

wget http://mirrors.kernel.org/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.161_all.deb 
sudo dpkg -i linux-firmware*.deb

After the update, reboot and let us know the results

Not the answer you're looking for? Browse other questions tagged or ask your own question.