2

Here are some infos about my computer:

lspci | grep Audio
00:05.0 Audio device: NVIDIA Corporation MCP61 High Definition Audio (rev a2)
02:00.1 Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)

And

 aplay -l
 **** List of PLAYBACK Hardware Devices ****
 card 0: NVidia_1 [HDA NVidia], device 0: ALC662 rev1 Analog [ALC662      rev1 Analog]
   Subdevices: 0/1
   Subdevice #0: subdevice #0
 card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
 card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

and

lspci -v | grep -A7 -i "audio"
00:05.0 Audio device: NVIDIA Corporation MCP61 High Definition Audio (rev a2)
Subsystem: ASRock Incorporation Device 3662
Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 22
Memory at dedf8000 (32-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel
00:06.0 IDE interface: NVIDIA Corporation MCP61 IDE (rev a2) (prog-if 8a [Master SecP PriP])

02:00.1 Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)
Subsystem: eVga.com. Corp. Device 1313
Flags: bus master, fast devsel, latency 0, IRQ 18
Memory at def7c000 (32-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel

I've set the number of chanels to 6

default-sample-channels = 6 

in etc/pulse/daemon.conf and

enable-lfe-remixing = yes

but in sound settings I don't have nothing concerning 5.1 audio.

PS. I have 3 jacks in the motherboard: mike, line out and line in.

In alsamixer I have soud cards

0 HDA NVidia

1 HDA NVidia

1

EDIT 1

I thought I resolved my issue by mounting a SC-5.1-3 Gembird sound card (~9 euro). It was recognized by Ubuntu without installing additional drivers. After this, I choose analog output 5.1 from sound settings.

BUT the volume does not work for rear and center speackers, only for front. AND every time I enter in sound settings it returns to 2 speacker stereo mode.

I even undo the 2 steps above. I put

 ; default-sample-channels = 6 
 ; enable-lfe-remixing = yes

in etc/pulse/daemon.conf but nothing changed:)

(the gembird drivers are from year 2000)

Is there a solution to this or should i control the volume for rear and center from the bass only?

EDIT 2

I tried alsamixer after uninstalling pulseaudio. (The volume applet disappeared). I did this folowing this tutorial http://www.hecticgeek.com/2012/01/how-to-remove-pulseaudio-use-alsa-ubuntu-linux/:

 sudo apt-get autoremove pulseaudio

and then from Software Center I installed gnome alsamixer.

I tested the 5.1 sound by (https://help.ubuntu.com/community/SurroundSound)

 speaker-test -Dplug:surround51 -c6 -l1 -twav

It worked fine but the volume controls from my keyboard didn't work as they did with pulse audio. Also didn't work on browsers in real 5.1.

Then I removed gnome alsa mixer and reinstalled the pulseaudio via Software center. It took a while(2 attempts) to figure aut how to install pulse audio. The config that worked for me was:

PulseAudio sound server (pulseaudio) with optional addons:

GStreamer plugin (gstreamer0.10-pulseaudio)

X11 module (pulseaudio-module-x11)

Realtime Policy and Watchdog Daemon (rtkit)

(these 3 were checked by default)

PulseAudio Manager (paman)

(by cheking this add-on, after installing pulse audio with the first 3 checked, I hit apply changes and The pulse manager was installed together with the next 3 add-ons from Software center: Preferences, Volume control and Volume meter).

Now I have 2 ways of accessing the sound settings:

  1. the one I was talking about earlier with "Sound" settings that every time I enter it makes the sound stereo.

2.and "PulseAudio Volume Control" that did the trick for me.

Anyway the problem with the volume being altered only in front speakers remains even dow in Volume Control it shoes all volumes (for all 6 channels) move at once, except mute that works for all 6 channels.

Also my System settings were broken after first pulseaudio uninstall and I repaired them at the end using this How to access System Settings when Ubuntu menu is broken?.

Also I did not altered the

 ; default-sample-channels = 6 
 ; enable-lfe-remixing = yes

in etc/pulse/daemon.conf after reinstalling so my daemon.conf has the above 2 lines unaltered and my 5.1 works by testing it with vlc and an *.ac3 file.

Regarding the browsers surround I found this Does YouTube support 5.1 surround sound? and stopped struggling.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.