0

I'm using Xubuntu 16.04. Although I active fcitx input method (Unikey and Hangul), It does not works for all application.

Here is my fcitx-diagnose

# System Info:
1.  `uname -a`:

        Linux 4.4.0-45-generic #66-Ubuntu SMP Wed Oct 19 14:12:37 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

2.  `lsb_release -a`:

        No LSB modules are available.
        Distributor ID: Ubuntu
        Description:    Ubuntu 16.04 LTS
        Release:    16.04
        Codename:   xenial

3.  `lsb_release -d`:

        Description:    Ubuntu 16.04 LTS

4.  `/etc/lsb-release`:

        DISTRIB_ID=Ubuntu
        DISTRIB_RELEASE=16.04
        DISTRIB_CODENAME=xenial
        DISTRIB_DESCRIPTION="Ubuntu 16.04 LTS"

5.  `/etc/os-release`:

        NAME="Ubuntu"
        VERSION="16.04 LTS (Xenial Xerus)"
        ID=ubuntu
        ID_LIKE=debian
        PRETTY_NAME="Ubuntu 16.04 LTS"
        VERSION_ID="16.04"
        HOME_URL="http://www.ubuntu.com/"
        SUPPORT_URL="http://help.ubuntu.com/"
        BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"
        UBUNTU_CODENAME=xenial

6.  Desktop Environment:

    Desktop environment is `xfce`.

7.  Bash Version:

        BASH_VERSION='4.3.42(1)-release'

# Environment:
1.  DISPLAY:

        DISPLAY=':0.0'

2.  Keyboard Layout:

    1.  `setxkbmap`:

            xkb_keymap {
                xkb_keycodes  { include "evdev+aliases(qwerty)" };
                xkb_types     { include "complete"  };
                xkb_compat    { include "complete"  };
                xkb_symbols   { include "pc+us+inet(evdev)" };
                xkb_geometry  { include "pc(pc105)" };
            };

    2.  `xprop`:

            _XKB_RULES_NAMES(STRING) = "evdev", "pc105", "us", "", ""

3.  Locale:

    1.  All locale:

            C
            C.UTF-8
            en_AG
            en_AG.utf8
            en_AU.utf8
            en_BW.utf8
            en_CA.utf8
            en_DK.utf8
            en_GB.utf8
            en_HK.utf8
            en_IE.utf8
            en_IN
            en_IN.utf8
            en_NG
            en_NG.utf8
            en_NZ.utf8
            en_PH.utf8
            en_SG.utf8
            en_US.utf8
            en_ZA.utf8
            en_ZM
            en_ZM.utf8
            en_ZW.utf8
            ko_KR.utf8
            POSIX

    2.  Current locale:

            LANG=en_US.UTF-8
            LANGUAGE=en_US
            LC_CTYPE="en_US.UTF-8"
            LC_NUMERIC=en_US.UTF-8
            LC_TIME=en_US.UTF-8
            LC_COLLATE="en_US.UTF-8"
            LC_MONETARY=en_US.UTF-8
            LC_MESSAGES="en_US.UTF-8"
            LC_PAPER=en_US.UTF-8
            LC_NAME=en_US.UTF-8
            LC_ADDRESS=en_US.UTF-8
            LC_TELEPHONE=en_US.UTF-8
            LC_MEASUREMENT=en_US.UTF-8
            LC_IDENTIFICATION=en_US.UTF-8
            LC_ALL=

4.  Directories:

    1.  Home:

            /home/trongkha

    2.  `${XDG_CONFIG_HOME}`:

        Environment variable `XDG_CONFIG_HOME` is not set.

        Current value of `XDG_CONFIG_HOME` is `~/.config` (`/home/trongkha/.config`).

    3.  Fcitx Settings Directory:

        Current fcitx settings directory is `~/.config/fcitx` (`/home/trongkha/.config/fcitx`).

5.  Current user:

    The script is run as trongkha (1000).

# Fcitx State:
1.  executable:

    Found fcitx at `/usr/bin/fcitx`.

2.  version:

    Fcitx version: `4.2.9.1`

3.  process:

    Found 3 fcitx processes:

        19239 fcitx
        24544 fcitx
        25691 fcitx-dbus-watc

4.  `fcitx-remote`:

    `fcitx-remote` works properly.

# Fcitx Configure UI:
1.  Config Tool Wrapper:

    Found fcitx-configtool at `/usr/bin/fcitx-configtool`.

2.  Config GUI for gtk2:

    **Config GUI for gtk2 not found.**

3.  Config GUI for gtk3:

    Found `fcitx-config-gtk3` at `/usr/bin/fcitx-config-gtk3`.

4.  Config GUI for kde:

    **`kcmshell4` not found.**

# Frontends setup:
## Xim:
1.  `${XMODIFIERS}`:

    **XMODIFIERS is not set**

    **Please set environment variable XMODIFIERS to "@im=fcitx" using the tool your distribution provides or add `export XMODIFIERS=@im=fcitx` to your `~/.xprofile`. See [Input Method Related Environment Variables: XMODIFIERS](http://fcitx-im.org/wiki/Input_method_related_environment_variables#XMODIFIERS).**
    Xim Server Name from Environment variable is fcitx.

2.  XIM_SERVERS on root window:

    Xim server name is the same with that set in the environment variable.

## Qt:
1.  qt4 - `${QT4_IM_MODULE}`:

    **Please set environment variable QT_IM_MODULE to "fcitx" using the tool your distribution provides or add `export QT_IM_MODULE=fcitx` to your `~/.xprofile`. See [Input Method Related Environment Variables: QT_IM_MODULE](http://fcitx-im.org/wiki/Input_method_related_environment_variables#QT_IM_MODULE).**

2.  qt5 - `${QT_IM_MODULE}`:

    **Please set environment variable QT_IM_MODULE to "fcitx" using the tool your distribution provides or add `export QT_IM_MODULE=fcitx` to your `~/.xprofile`. See [Input Method Related Environment Variables: QT_IM_MODULE](http://fcitx-im.org/wiki/Input_method_related_environment_variables#QT_IM_MODULE).**

3.  Qt IM module files:
    Found fcitx im module for Qt4: `/usr/lib/x86_64-linux-gnu/qt4/plugins/inputmethods/qtim-fcitx.so`.
    Found fcitx im module for Qt5: `/usr/lib/x86_64-linux-gnu/qt5/plugins/platforminputcontexts/libfcitxplatforminputcontextplugin.so`.

## Gtk:
1.  gtk - `${GTK_IM_MODULE}`:

    **Environment variable GTK_IM_MODULE is "xim" instead of "fcitx". Please check if you have exported it incorrectly in any of your init files.**
    **You are using xim in gtk programs.**

    **To see some application specific problems you may have when using xim, check [Hall of Shame for Linux IME Support](http://fcitx-im.org/wiki/Hall_of_Shame_for_Linux_IME_Support). For other more general problems of using XIM including application freezing, see [here](http://fcitx-im.org/wiki/XIM).**

    **Please set environment variable GTK_IM_MODULE to "fcitx" using the tool your distribution provides or add `export GTK_IM_MODULE=fcitx` to your `~/.xprofile`. See [Input Method Related Environment Variables: GTK_IM_MODULE](http://fcitx-im.org/wiki/Input_method_related_environment_variables#GTK_IM_MODULE).**

2.  `gtk-query-immodules`:

    1.  gtk 2:

        **Cannot find `gtk-query-immodules` for gtk 2**

        **Cannot find fcitx im module for gtk 2.**

    2.  gtk 3:

        **Cannot find `gtk-query-immodules` for gtk 3**

        **Cannot find fcitx im module for gtk 3.**

3.  Gtk IM module cache:

    1.  gtk 2:

        Found immodules cache for gtk `2.24.30` at `/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules.cache`.
        Version Line:

            # Created by /usr/lib/x86_64-linux-gnu/libgtk2.0-0/gtk-query-immodules-2.0 from gtk+-2.24.30

        Found fcitx im modules for gtk `2.24.30`.

            "/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules/im-fcitx.so" 
            "fcitx" "Fcitx (Flexible Input Method Framework)" "fcitx" "/usr/share/locale" "ja:ko:zh:*" 

    2.  gtk 3:

        Found immodules cache for gtk `3.18.9` at `/usr/lib/x86_64-linux-gnu/gtk-3.0/3.0.0/immodules.cache`.
        Version Line:

            # Created by /usr/lib/x86_64-linux-gnu/libgtk-3-0/gtk-query-immodules-3.0 from gtk+-3.18.9

        Found fcitx im modules for gtk `3.18.9`.

            "/usr/lib/x86_64-linux-gnu/gtk-3.0/3.0.0/immodules/im-fcitx.so" 
            "fcitx" "Fcitx (Flexible Input Method Framework)" "fcitx" "/usr/share/locale" "ja:ko:zh:*" 

4.  Gtk IM module files:

    1.  gtk 2:

        All found Gtk 2 immodule files exist.

    2.  gtk 3:

        All found Gtk 3 immodule files exist.

# Configuration:
## Fcitx Addons:
1.  Addon Config Dir:

    Found fcitx addon config directory: `/usr/share/fcitx/addon`.

2.  Addon List:

    1.  Found 25 enabled addons:

            fcitx-autoeng
            fcitx-chttrans
            fcitx-classic-ui
            fcitx-clipboard
            fcitx-dbus
            fcitx-freedesktop-notify
            fcitx-fullwidth-char
            fcitx-hangul
            fcitx-imselector
            fcitx-ipc
            fcitx-keyboard
            fcitx-kimpanel-ui
            fcitx-lua
            fcitx-notificationitem
            fcitx-punc
            fcitx-quickphrase
            fcitx-remote
            fcitx-spell
            fcitx-unicode
            fcitx-unikey
            fcitx-vk
            fcitx-x11
            fcitx-xim
            fcitx-xkb
            fcitx-xkbdbus

    2.  Found 0 disabled addons:

3.  Addon Libraries:

    All libraries for all addons are found.

4.  User Interface:

    Found 2 enabled user interface addons:

        fcitx-classic-ui
        fcitx-kimpanel-ui

## Input Methods:
1.  Found 2 enabled input methods:

        fcitx-keyboard-us
        unikey

2.  Default input methods:

    You have a keyboard input method "fcitx-keyboard-us" correctly added as your default input method.

# Log:
1.  `date`:

        Sat Oct 29 19:09:27 KST 2016

2.  `~/.config/fcitx/log/`:

        total 0
        -rw-rw-r-- 1 trongkha trongkha 0 Oct 29 19:00 crash.log

3.  `~/.config/fcitx/log/crash.log`:
  • Have you tried using the shortcut Ctrl + Space to change the current input method? And did the fcitx icon on the taskbar change from a keyboard to a colorful V? – PyGeek03 Oct 31 '16 at 2:50
  • Yes. I tried but the fcitx icon did not change to a colorful V. However, the fcitx Unikey method options showed in menu. – fluke-ng Nov 1 '16 at 14:04
  • Well you should try pressing that shortcut a few times until it works, which is my experience. If that still doesn't work, left-click the icon, choose Configure, then select the Global Config tab on the window that appears to check if Trigger Input Method under Hotkey is set to Ctrl + Space and Ctrl + Shift + Space, as well as whether Enable Hotkey to scroll Between Input Method checkbox is ticked. When it does work, an underline will appear under the words you type. – PyGeek03 Nov 1 '16 at 14:20
  • I followed your instruction but it does not work. – fluke-ng Nov 3 '16 at 15:23
  • How about reinstalling fcitx and fcitx-unikey? sudo apt purge fcitx fcitx-unikey and then sudo apt install fcitx fcitx-unikey – PyGeek03 Nov 3 '16 at 15:25
0

On my machine fcitx got autostarted by im-config under (X)Ubuntu 16.04 see /usr/share/im-config/ Even when you deinstalled all fcitx packages, im-config would still invoke fcitx. Therefore I recommend you to also check if you have im-config installed and how it is configured. (In my case im-config autostarted an fcitx process that eat up all memory and made my machine unusable).

Why is that relevant?

My guess is that im-config improperly launches (or was previously improperly configured to launch) its own fcitx binary that may interfere with the actual packaged fcitx tool set. This means while you suspect the running fcitx to be the one that came with the package manager in reality another, potentially older version of fcitx gets run and gets in trouble with your system. As a consequence the recommendations above to reinstall the fcitx would not change/improve anything.

What your im-config is set to do could be found in /usr/share/im-config/

I had this behaviour on my machine and it could be either a packaging bug or a legacy configuration bug or an upgrade bug (I previously had Ubuntu Kylin installed and dist-upgraded multiple times). I would recommend you to backup the im-config configuration files in /usr/share/im-config/, and then purge im-config, delete all files in /usr/share/im-config/ if any and reinstall a clean, fresh installation of im-config.

  • im-config does not launch anything improperly. It launches fcitx and sets the related environment variables if you have told it so. It's simplest to use Language Support to control im-config. (Please see my answer.) – Gunnar Hjalmarsson Nov 20 '16 at 19:32
  • The issue is widely reported: you completely deinstall fcitx, so it should not be there anymore, and still im-config executes fcitx. So my guess was that im-config keeps its own copy. The cause of this behaviour could be on various levels. – andrelin Dec 8 '16 at 10:17
  • Many misconceptions are widely reported; this may be one of them. Fcitx consists of multiple packages, and the one you need to uninstall to tell im-config that Fcitx is uninstalled is fcitx-bin. Besides, im-config doesn't try to launch Fcitx if you tell it not to e.g. through Language Support. – Gunnar Hjalmarsson Dec 8 '16 at 13:48
0

Try rm -rf ~/.config/fcitx and restart ubuntu, this fixed me at least, on xubuntu 16.04

-1

Open Language Support, select fcitx as the "keyboard input method system", and relogin.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.