1

When I try to use the command airodump-ng mon0 it returns device not found

How do I solve this?

dani@danish:~$ sudo airmon-ng start wlp12s0

Found 5 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!

PID Name
795 NetworkManager
808 avahi-daemon
911 avahi-daemon
994 wpa_supplicant
1133    dhclient
Process with PID 1133 (dhclient) is running on interface wlp12s0

Interface   Chipset     Driver

wlp12s0     Broadcom    wl - [phy0]mon0: ERROR while getting interface flags: No such device

                (monitor mode enabled on mon0)
7
  • Um, what's your question?
    – Kaz Wolfe
    Oct 30 '16 at 21:04
  • bro mon0 device not found, when i try to use cammand "airodump-ng mon0" it gives error device not found
    – Dani
    Oct 30 '16 at 21:18
  • Please edit your question to include this additional data.
    – Kaz Wolfe
    Oct 30 '16 at 21:20
  • what exactly u wanna know i mean im new in this thing so plz define?
    – Dani
    Oct 30 '16 at 21:23
  • First off, don't use plz, u, etc. Take some time to actually be coherent. We take time to help you. Oct 31 '16 at 0:10
1

It is rather well known that the Broadcom STA driver doesn't support monitor mode. You can confirm this yourself:

iw list

My wireless card reports:

Supported interface modes:
         * IBSS
         * managed
         * AP
         * AP/VLAN
         * monitor
         * P2P-client
         * P2P-GO
         * P2P-device

Moreover, for almost all Broadcom devices, one and only one driver supports the device. For these, we know of no alternate driver that works at all, much less provides monitor mode.

6
  • iw list............Supported commands: * set_interface * new_key * join_ibss * set_pmksa * del_pmksa * flush_pmksa * connect * disconnect software interface modes (can always be added): interface combinations are not supported Device supports scan flush.
    – Dani
    Oct 30 '16 at 21:21
  • monitor mode enabled on mon0 but device not found ?
    – Dani
    Oct 30 '16 at 21:24
  • what should i exactly do?
    – Dani
    Oct 30 '16 at 21:31
  • Get a different device.
    – chili555
    Oct 30 '16 at 21:45
  • Give me any other suggestion plz
    – Dani
    Oct 30 '16 at 22:00
0

There are two possible reasons for this error:

  1. Device is in use: Kill all processes mentioned which could cause trouble, e.g.

    kill -9 994 (kills your wpa_supplicant)

  2. Update to latest airmon-ng version: The documentation suggests to update to the latest version from svn.

5
  • its updated already ive checked. and i have tried kill but no working for me
    – Dani
    Oct 30 '16 at 21:41
  • You have to kill the five processes mentioned , if airmon-ng still warns you about them that means that they are still running.
    – storm
    Oct 30 '16 at 21:43
  • im killing but i gives again again new process?
    – Dani
    Oct 30 '16 at 21:47
  • How to kill at once
    – Dani
    Oct 30 '16 at 21:52
  • I kiled all with Aircrack-ng check kill but still not working
    – Dani
    Oct 30 '16 at 21:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.