5

example

Here is same image open in Chrome, feh, and Ubuntu's default image viewer (http://www.flatdesigncolors.com/assets/colors.png).

Can someone explain what is happening here, how can I know which representation is most accurate, and how to make it appear the same in different applications?

1
  • I have this issue too. The problem, as far as I can tell, is in the default image viewer (the eye of gnome), as all other image viewers and programs (Firefox, Mirage, ViewNior, etc.) show images correctly. Anyone found a solution yet? Jul 11, 2018 at 11:25

3 Answers 3

2

Solution

Actually, I think I've found a workaround. I've done some digging, and as this answer says, you need to remove a rogue ICC profile. Here's how you do that:

xprop -root -remove _ICC_PROFILE

Persisting upon Reboot

There are reports floating around that it resets upon reboot, so if this happens to you, then try adding the command to ~/.profile. To do that execute this command:

gedit ~/.profile

The text editor will now open. Paste the command at the bottom of the file. I suggest you add a comment (A line preceded by a hash #) to remind your future self as to what it does.

0
0

You could also delete the colour profile in colour settings.

If the remove button is greyed out, you can simply deny access to the colour profile files:
$ sudo chmod 000 ~/.local/share/icc

0

As I answered here (and I'm pasting the answer in the following lines), a GUI solution could be going to Settings -> Color and disabling the Laptop Screen option (maybe another option might appear to you, so I recommend try each and see if it solves the problem). Your printer colors profile might be here too, so make sure to let disabled only the option that solves your problem.

Warning: I don't know all the consequences of this change, but it's unlikely that something dangerous occurs (like you getting a black screen).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .