1

This is a separate error from ERROR: 32-bit Linux Android emulator binaries are DEPRECATED but I am getting the same error message.

I'm currently running:

  • Ubuntu 16.04.1 LTS
  • kernel Linux 4.4.0-45-generic(x86_64)
  • Desktop environment LXDE
  • 64-bit Java Server VM

I've seen previous results dealing with this same error and suggesting an update to a 64 bit Linux but clearly I already am. Running the avd with 32Bit forced results in the following error.

Starting emulator for AVD 'Nexus_5_API_22' sh: 1: glxinfo: not found [140514843576128]:ERROR:./android/qt/qt_setup.cpp:28:Qt library not found at /opt/Android/Sdk/tools/lib/qt/lib Could not launch '/opt/Android/Sdk/tools/qemu/linux-x86/qemu-system-x86_64': No such file or directory

the reason this is missing is because there is no linux-x86 folder only linux-x86_64/qemu-system-x86_64

Is there any way I can get this running, preferably in the supported 64-bit mode?

0

I hope this will solve your problem.
I had a freshly installed latest Android Studio and perform all basic steps to run a 'Hello World' project in emulator
but had a same problem while running emulator from avd manager.
After that i tried running emulator from command line also but faced same problem.
After long debugging i came to find out that it was missing some core library,
and then solved the problem by selecting checkbox and install emulator from Android Studio Options.

Tools -> Android -> SDK Manager -> SDK Tools -> Android Emulator

And click Apply and Run project again.
Note :- If already Checked try to reinstall it.
Now its working like a charm.Sample Screenshot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.