3

Without any cause that I can tell, all text has turned into boxes /rectangles everywhere in Ubuntu 16.04.

I am able to press ctrl-alt-F1 and go to shell, I have run :

apt-get update

And

apt-get upgrade

But this has not changed anything.

Any suggestions?

3
  • 1
    Try fc-cache -fr (and reboot). Oct 30, 2016 at 15:57
  • This happens for me too. I just log out and log in back to fix it. Oct 30, 2016 at 16:18
  • Have you tried (re)setting the system language & region settings? They are in System Settings / Language Support. After setting them, click "Apply System Wide" (assuming all users on your computer share locale preferences). Note: changes take effect after reboot.
    – zwets
    Oct 30, 2016 at 17:56

1 Answer 1

10

This can be the result of some invalid permissions settings on Font files. You need to set correct permissions for fonts.

To fix the permissions of all fonts ending with .ttf or .otf extension use these two commands.

find /usr/share/fonts -iname '*.ttf' -type f -exec sudo chmod -v 644 {} \;
find /usr/share/fonts -iname '*.otf' -type f -exec sudo chmod -v 644 {} \;

Then use this command to re-build font cache

sudo fc-cache -r -v

This should fix the problem.

2
  • +1, work like a charm !!! Dec 5, 2020 at 8:47
  • The two chmod lines can be shortened to one: find /usr/share/fonts -iname '*.[ot]tf' -type f -exec sudo chmod -v 644 {} \;
    – thoredge
    Aug 4, 2021 at 7:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.