note to future users who come across this question

this question has been tagged as a possible duplicate of

That question is about the whole process of having the OS apt-get update and apt-get upgrade packages automatically - not the popup manager window.
However this question is a duplicate of this:

It turns out the update manager popup cannot be managed through apt's configuration files, it acts as an independent daemon and needs to be managed separately.

Every morning when I log into my install of Ubuntu 16.04.1 I get this:

enter image description here

I don't want this box to appear, as I would rather handle the updating process manually.

I have the following configuration:

file: /etc/apt/conf.d/10periodic

APT::Periodic::Update-Package-Lists "0";
APT::Periodic::Download-Upgradeable-Packages "0";
APT::Periodic::AutocleanInterval "0";
// Try and turn off autoupating
APT::Periodic::Enable "0";

file: /etc/apt/conf.d/20auto-upgrades

APT::Periodic::Update-Package-Lists "0";
APT::Periodic::Unattended-Upgrade "0";

My attempt to discover what is responsible for firing the automatic update system

man apt.conf states:

APT::Periodic and APT::Archives groups of options configure behavior of
apt periodic updates, which is done by the /etc/cron.daily/apt script.
See the top of this script for the brief documentation of these options.

It looks like this has been replaced by /etc/cron.daily/apt-compat which mixes times abit so everyones Ubuntu doesn't try update at once then it calls:


/usr/lib/apt/apt.systemd.daily is a shell script that starts with a comment:

This file understands the following apt configuration variables:
Values here are the default.
Create /etc/apt/apt.conf.d/10periodic file to set your preference.

so following this advice I entered this

    // Try and turn off autoupating
    APT::Periodic::Enable "0";

into /etc/apt/apt.conf.d/10periodic as you can see from my config listing above. yet I am still getting the notification...

Possible solutions I can think of

  • the comment // Try and turn off autoupating may be causing a parse error of the config file, causing apt to ignore the entire file?
  • unlinking or commenting out /etc/cron.daily/apt-compat ?

How can I disable the update notifier box?

  • @DKBose thanks for pointing that out. have you noticed any problems associated with killing the update notifier daemon? – the_velour_fog Oct 30 '16 at 3:15

Browse other questions tagged or ask your own question.