2

I am running Ubuntu 16.04 and I am having trouble sharing my wired internet connection with my SmartTV.

My setup is a single on-board Gigabit port (enp3s0) and a separate 100Mbit PCIe card (enp6s0).

The enp3s0 is connected directly to the RJ45 socket in the wall. It connects with DCHP and works flawlessly.

I wish to allow the SmartTV, which is connected via a cat5e cable to the second NIC enp6s0, to have full access to the internet connection.

The TV is a Samsung UE55HU7500. It's quite limited as to what settings I can change regarding networking. I can set it to "Get Settings Automatically" or enter the values for IP Address, Subnet Mask, Gateway and DNS Server.

Setting it to Automatic and connecting the TV to the wall works fine. I know this can be fixed with a switch, but right now that's not an option.

I have been trying for a while now but my limited networking skills are not really helping. Hopefully someone can provide me with a simple explanation of how to get this working.

1
  • 1
    @wjandrea: please use "reject and edit" more carefully in the future as these are lower-level users then you and not as accustomed to the rules yet. Better to "accept and edit" and leave a comment then what you did... Only when it's really bad should you reject and edit. If you disagree, drop by in chat to kick me! ;-)
    – Fabby
    Nov 6, 2016 at 19:59

1 Answer 1

3

If you are using a GUI: (Only works for IPv4)

  1. Go in to the Network Connections setting
  2. Click Add
  3. Select Ethernet then click create
  4. Use the drop-down list by the device option to enp6s0, or the desired device.
  5. Click the IPv4 Settings tab
  6. Click on the drop-down box beside Method, and change it to Shared to other computers
  7. Click Save, then Close

Note: The TV, in this case, will not get an IP address registered by the router. It will still be able to access other LAN computers & the Internet, but other computers can't (without tunneling) access it.

2
  • I hope I clarified well enough that this is meant to be done on the Ubuntu computer, not the TV.
    – luk3yx
    Oct 30, 2016 at 2:11
  • That was extremely simple! Thanks a million for your help. Worked like a charm. It's amazing how long I messed around with this and didn't come up with that! Oct 30, 2016 at 2:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.