0

I am using Ubuntu 16.04 on an Asus ZenBook UX305. I have recently changed my router to a HUAWEY HG633 and I am unable to connect to the wifi network. The same router works fine through the Ethernet connection. The same wifi connections work fine on other Windows laptops and a few mobile phones but not on Linux.

After running dmesg I get the following message

[ 2879.219757] wlan0: authenticate with 60:83:34:2d:d6:fc
[ 2879.226060] wlan0: send auth to 60:83:34:2d:d6:fc (try 1/3)
[ 2879.226517] wlan0: authenticated
[ 2879.230953] wlan0: associate with 60:83:34:2d:d6:fc (try 1/3)
[ 2879.232039] wlan0: RX AssocResp from 60:83:34:2d:d6:fc (capab=0x411 status=0 aid=3)
[ 2879.234649] wlan0: associated
[ 2879.234718] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 2879.240962] wlan0: disassociated from 60:83:34:2d:d6:fc (Reason: 14)
[ 2904.309137] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

I am unable to move forward and identify further steps to debug the problem. Any help would be greatly appreciated.

1 Answer 1

1

When I read that a new router has been installed, I get nervous because often, routers are put in place with default settings that work fine for most wireless devices but may not work well with Linux drivers that are often very sensitive to settings in the router or other access point.

Please check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

Next, I recommend that your regulatory domain be set explicitly. Check yours:

sudo iw reg get

If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

sudo iw reg set IS

Of course, substitute your country code if not Iceland. Set it permanently:

gksudo gedit /etc/default/crda

Use nano or kate or leafpad if you don't have the text editor gedit.

Change the last line to read:

REGDOMAIN=IS

Proofread carefully, save and close the text editor.

Next, I'd set IPv6 to Ignore in Network Manager: http://docs.fedoraproject.org/en-US/Fedora/18/html/Installation_Guide/images/netconfig/network-connections-ipv6-ignore.png This example is for ethernet, but you want wireless.

After making these changes, let us hear if connectivity is improved.

2
  • Problem solved. Changing the router settings to WPA2-AES and to 20 MHz in the 2.4 GHz band was enough to connect. Thanks
    – Abdd
    Oct 30, 2016 at 9:22
  • "may not work well with Linux drivers that are often very sensitive to settings" - that perhaps suggests that the driver(s) in question might not be tested enough in different environments, or need a "strict/non-strict" option to allow operation with more permissive / prescriptive settings.
    – MikeW
    Mar 15, 2019 at 11:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.