1

I'm running Ubuntu 16.04 in Virtualbox. Asides from some slowness it's working fine, except for the User interface being very slow. For example, window animations do not happen, windows just pop up, or transparency or blur. This isn't a huge issue, but being used to the smoothness of Unity makes this quite a jarring experience.

Is this just a fact of it being on a virtual machine, or can it be fixed?

3
  • It can be fixed. Shutdown your VM. Go to settings and set your CPU count = 2, video memory =128K, system memory = 2048, 3D accel = on, and it should fly. Let me know. Cheers, Al
    – heynnema
    Oct 29, 2016 at 15:02
  • Install a 2D desktop environment, such as LXDE. Oct 29, 2016 at 15:25
  • What is the specs of your server and how much resources you allocated to the VM?
    – teclinux
    Jul 9, 2020 at 16:27

2 Answers 2

0

You may also try to enable 3d acceleration in VirtualBox

Select your VM on the LHS Settings -> Display - > Video tab, "Enable Features:" and check the Enable 3D Acceleration box Click OK

You may try to adjust video memory see the image with the settings below

https://nautilusmode.com/wp-content/uploads/2015/09/11_virtualbox_tutorial_settings_display_screen.png

0

Apart from enabling '3D' support in VirtualBox I also ran the following command.

sudo bash -c 'echo vboxvideo >> /etc/modules'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.