0

I recently upgraded from 14.04 to 16.04 and tried locating the VMWare Horizon View Client package by using steps outlined here: How to install VMware View Client?

I received the following error :

E: Unable to locate package vmware-view-client

Therefore, it seems it is not yet available in the repositories for 16.04.

It looks like it can be downloaded from the VMWare website. To assist with this process, there are some threads about installing VMWare View Client downloaded from website above and getting it to work such as this one.

I am fairly new to Ubuntu and am unsure if there is a greater security risk installing something directly from the VMWare website from which my system will not receive periodic package updates. However, I was able to successfully install the package from the website above. Unfortunately, when I tried to connect to my employer's server, it would just jump back to the login screen. I am able to successfully connect to my employer's server on another machine running Windows, and so this problem is isolated to this case.

Should I expect this package to eventually be added to the repositories for 16.04? If I need to stick with the direct download from the VMWare website, are there additional packages that need to be installed to get VMWare Horizon View Client to work correctly on 16.04?

4
  • what is the output of : whereis vmware-view-client
    – Mr. Pundir
    Oct 29, 2016 at 11:45
  • Thank you for your comment! The output is "vmware-view-client:" There isn't anything after the ":" and so it must not exist, right?
    – OpnSrcFan
    Oct 29, 2016 at 12:04
  • you should type in terminal -> whereis vmware-view-client
    – Mr. Pundir
    Oct 29, 2016 at 13:08
  • Thank you, I tried this and the output on the next line was "vmware-view-client:" It was blank after the colon.
    – OpnSrcFan
    Oct 29, 2016 at 13:12

1 Answer 1

0

This is how i installed 64 bit version 4.7 ... hope this is useful to someone who happens to stumble on it in their searches (I did not have to install any dependencies or create symbolic links prior to installing successfully):

1) Download Linux client from from https://www.vmware.com/go/viewclients

2) Uninstall any previous version (if any).

3)

  • a) Open a Terminal window.
  • b) Change directories to the directory that contains the installer file (xxx.bundle).

4) Run the installer with the following command:

sudo sh ./VMware-Horizon-Client-x.x.x-yyyyyyy.arch.bundle

*or in my case:

sudo sh ./VMware-Horizon-Client-4.7.0-7395152.x64.bundle

(To note: the "sh" is there to "force" the bundle to be executable.. depending on the permissions YOU have set forth this will also work:

sudo ./VMware-Horizon-Client-x.x.x-yyyyyyy.arch.bundle

5) Follow the Gui install wizard..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.