3

RESOLVED!! Ubuntu 16.04:

In software additional driver, For GT630 - Nvidia-340 is the driver available and for GT610 - Nvidia-304 is available. Installing one of them doesn't work out for both monitors. I wonder if I can install both and specify which driver to use for that specific device because:

SOLVED I'll reply with working copy of xorg.conf. I kinda messed up something else after it was resolved. Trying to fix this issue now. Have backed up working copy of Xorg.conf.

1) If I install Nvidia-340 it only works for first monitor, second monitor has no display. If Xinerma is enabled, secondary monitor has Ubuntu Logo in the center and mouse can be moved. But window can't be moved and no menu bar.

xorg.0.log:

  nvidia-1 : No input driver specified, ignoring this device.
  nvidia-1 : This device may have been added with another device file.

Nouveau is being used for GT610 by default.

If I blacklist-nouevea, reboot, then rather than Ubuntu Logo, it is just a black screen and I can move my mouse on that monitor (X cursor).

2) If I install Nvidia-304 and restart then low graphic memory error and I will have to press alt+shift+f1 and purge nvidia-304 to get display back.

I guess nvidia-304 would not work for GT630 and nvidia-340 won't work for GT610? And both can't have 2 different drivers????

Screen 1 - GT630

Screen 2 - GT610

Once I enable Xinerma, I can't access display properties (Xrandr extension not present). So I go to nvidia-settings and In X Server settings, both display are enabled and in X Screen 0 options both GPU listed). Should there be a X Screen 1, with GPU as GT610 right?

UPDATE: I can see X Screen 1 in nvidia-settings after I rebuilt Xorg.conf and now in lock window, if I mouse hover to secondary monitor, login prompt switches to secondary monitor. I can login too. But still there is a problem....

Ubuntu Logo is finally gone but no MENU bar and the default background is on top of everything?. I can move the window to next monitor but I can't see it. Its behind the default background.. If I can predict, I can drag the window back to screen 1. If I change wallpaper, it is only visible in Monitor 1 unless I restart lightdm, still a stuck background btw.

Please someone suggest me something,.. Kinda getting close to fix this. Just so you know this is the second time I'm installing Ubuntu in the last 3 months to try and fix it once and for all. I need to get it up during this weekend, if not - switch Nouveau drivers or Switch to Windows.

How I rebuilt xorg? : I opened nvidia-setting and deleted xorg.conf and saved.

If I enable Base-Mosiac then secondary monitor will get disabled and will not be visible in nvidia-setting. I manually tried to turn on Base-Mosiac in xorgs.conf but still nothing on secondary monitor.

Closest I can get to is with 340 drives and Ubuntu Logo centered on secondary monitor.

3) I'd like mention that nouveva drivers work for dual monitor except that for First monitor, mouse always flicker.. like 1000 times in a minute when playing video, without video a couple of 100 times in a minute (still very annoying). It doesn't flicker on secondary monitor.

xorgs.conf - updated

Section "ServerLayout"
Identifier     "Layout0"
Screen      0  "Screen0" 0 0
Screen      1  "Screen1" RightOf "Screen0"
InputDevice    "Keyboard0" "CoreKeyboard"
InputDevice    "Mouse0" "CorePointer"
Option         "Xinerama" "1"
EndSection

Section "Files"
EndSection

Section "Module"
Load           "dbe"
Load           "extmod"
Load           "type1"
Load           "freetype"
Load           "glx"
EndSection

Section "InputDevice"

# generated from default
Identifier     "Mouse0"
Driver         "mouse"
Option         "Protocol" "auto"
Option         "Device" "/dev/psaux"
Option         "Emulate3Buttons" "no"
Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier     "Keyboard0"
Driver         "kbd"
EndSection

Section "Monitor"

# HorizSync source: edid, VertRefresh source: edid
Identifier     "Monitor0"
VendorName     "Unknown"
ModelName      "Samsung"
HorizSync       30.0 - 81.0
VertRefresh     56.0 - 75.0
Option         "DPMS"
EndSection

Section "Monitor"

# HorizSync source: unknown, VertRefresh source: unknown
Identifier     "Monitor1"
VendorName     "Unknown"
ModelName      "Samsung"
HorizSync       30.0 - 81.0
VertRefresh     56.0 - 75.0
Option         "DPMS"
EndSection

Section "Device"
Identifier     "Device0"
Driver         "nvidia"
VendorName     "NVIDIA Corporation"
BoardName      "GeForce GT 630"
BusID          "PCI:1:0:0"
EndSection

Section "Device"
Identifier     "Device1"
Driver         "nvidia"
VendorName     "NVIDIA Corporation"
BoardName      "GeForce GT 610"
BusID          "PCI:2:0:0"
EndSection

Section "Screen"

Identifier     "Screen0"
Device         "Device0"
Monitor        "Monitor0"
DefaultDepth    24
Option         "nvidiaXineramaInfoOrder" "CRT-0"
Option         "Stereo" "0"
Option         "metamodes" "nvidia-auto-select +0+0"
Option         "SLI" "Off"
Option         "MultiGPU" "Off"
Option         "BaseMosaic" "off"
SubSection     "Display"
    Depth       24
    EndSubSection
EndSection

Section "Screen"
# Removed Option "BaseMosaic" "on"
Identifier     "Screen1"
Device         "Device1"
Monitor        "Monitor1"
DefaultDepth    24
Option         "nvidiaXineramaInfoOrder" "CRT-1"
Option         "Stereo" "0"
Option         "metamodes" "nvidia-auto-select +0+0"
Option         "SLI" "Off"
Option         "MultiGPU" "Off"
Option         "BaseMosaic" "off"
SubSection     "Display"
    Depth       24
    EndSubSection
EndSection
2

Main change was just one line in xorg.conf. Both cards are using Nvidia-340 driver now because nouevea is blacklisted.

Screen      1  "Screen1" RightOf "Screen0"
Changed as
Screen      1  "Screen1" 1440 0

Then make it read-only so during reboot it doesn't get changed: chmod 440 /etc/X11/xorg.conf

That got my second display working. If that is not the case, Check which PCI slot (lshw) of your primary monitor and try flipping the bus ID and BoardName. OR rather rebuild xorg.conf. Just open nvidia-setting and then delete xorg.conf and click save in nvidia-setting

Section "Device"
Identifier     "Device0"
Driver         "nvidia"
VendorName     "NVIDIA Corporation"
BoardName      "GeForce GT 610" <- before it was 630
BusID          "PCI:2:0:0"      <- before it was 1:0:0

Section "Device"
Identifier     "Device1"
Driver         "nvidia"
VendorName     "NVIDIA Corporation"
BoardName      "GeForce GT 630"
BusID          "PCI:1:0:0"

Its all about xorg.conf. Play with it and it should work. In case if your theme/unity window gets messed up, follow these steps.

Steps:

  1. Press ctrl + alt + f1
  2. sudo service lightdm stop
  3. rm ~/.config/dconf/user
  4. sudo service lightdm start

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.