0

I'm trying to install from a ubuntu-16.04.1-desktop-amd64.iso live USB drive. It fails in different ways depending on my choices to the installer.

Way 1: I boot the installer, connect to my wi-fi network, and check "Download updates while installing". I can get to the "Install Now" step, after "Erase disk and install Ubuntu" (with "Use LVM" checked, though that may not be important, since I tried other things below). I click "Install Now", a window pops up with the partition info, and I click permission to go ahead -- and then it seems to get stuck with a spinning cursor. (I waited at least 30 minutes, probably over an hour.) What might be wrong? What can I do to find out? Was it just downloading updates all that time without saying what it's doing?

The sha256sum of the ISO checks out. When I wrote it to the USB drive (using Rufus USB installer, following the directions), I set the "Check device for bad blocks" option, and it passed.

The first time I tried to install, I picked "Install alongside Windows" instead of "Erase disk", and it seemed to hang up the same way. Maybe it was repartitioning for hours while displaying the spinning white cursor and not letting me do anything -- that's plausible -- but the behavior I could see was the same. (I decided I didn't want the Windows install enough to wait more hours on repartitioning, and powered it off.)

Way 2: If instead I click the "Try Ubuntu" button at the start, the screen goes to text mode and an infinite list of printk messages scroll by too quickly to read. Bits I can make out sometimes: "n printk messages dropped"; "pcieport"; "PCIe bus error" (I think); "receiver layer error status" (I think?); "mask=00..."; "Physical Layer"; "id=00e0 (Receiver ID)".

Way 3: Like way 1, but without connecting to wifi, or checking "Download updates". Now it gets further, to setting up keyboard layout, my name and password, and time zone. It starts apparently installing the OS to disk. After a short wait, it reports "We're sorry, the installer crashed." saying it's out of disk space. If I had to guess, it might not have properly recovered from the interruption of the repartitioning from back when I tried Way 1, although AFAIK it should not matter because this fresh install is supposed to erase whatever was on the disk before.

This is a new Dell XPS 8900 which ran Windows 7 Professional with no problem.

Update: I did not figure this out but did manage to install Debian instead. It'd be good to have a better idea what went wrong, but I'm not going to mess with the Debian install.

13
  • Welcome to Ask Ubuntu! ;-) Did you format the disks?
    – Fabby
    Oct 28 '16 at 21:29
  • Thanks, @Fabby. I didn't do anything extra to format the hard drive, if that's what you mean -- I thought the "Erase disk and install Ubuntu" option did that. If you mean the USB drive, I used the default option from Ubuntu's instructions that I linked to above (ISOHybrid image, step 4 of ubuntu.com/download/desktop/create-a-usb-stick-on-windows ) Oct 28 '16 at 22:06
  • You've erased your disk anyway, so use DBAN to fully nuke your disk and try again. If that doesn't work, hit [ctrl][s] to stop the scrolling and leave another comment with the exact error message.
    – Fabby
    Oct 28 '16 at 22:14
  • I did try ctrl-s originally and it did not pause it. There was a brief change in the messages scrolling by, too fast for me to see the new ones. I'll check out DBAN, thanks. Oct 28 '16 at 23:05
  • Did [pause] work?
    – Fabby
    Oct 28 '16 at 23:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.