1

Using Ubuntu 16.04 with workspaces enabled in System Settings -> Appearance.

When I am in a workspace and I click the launcher for an application (Chrome, say) then it automatically kicks me over to the next workspace where Chrome is already open.

The behavior I'd like is for separate workspaces to have zero knowledge of applications/windows that are open in another workspace (at least for the practical purpose of opening new copies of an application).

Without altering the particular UI manager I'm using at all (e.g. without switching to gnome classic or something), how do I enable to desired behavior described above?

I've checked this question but none of the answers seem to address the actual underlying problem.

  • Not even middle-click works??? Leave a comment @Fabby. – Fabby Oct 28 '16 at 21:46
  • Middle click works, but is not reasonable. Clicking on, say, 'Chrome' when I am in a workspace where Chrome is not currently opened is not a signal that I want to switch out of that workspace and go to wherever Chrome is open. That essentially defeats the entire purpose of workspaces. – ely Oct 28 '16 at 21:50
0

What you're trying to do is impossible without downloading the source and programming it in yourself.

See:

gsettings list-recursively | grep-red --ignore-case "switch" | grep-blue --ignore-case workspace
org.gnome.desktop.wm.keybindings switch-to-workspace-down ['<Control><Alt>Down']
org.gnome.desktop.wm.keybindings switch-to-workspace-1 ['<Super>Home']
org.gnome.desktop.wm.keybindings switch-to-workspace-2 ['disabled']
org.gnome.desktop.wm.keybindings switch-to-workspace-3 ['disabled']
org.gnome.desktop.wm.keybindings switch-to-workspace-4 ['disabled']
org.gnome.desktop.wm.keybindings switch-to-workspace-7 ['disabled']
org.gnome.desktop.wm.keybindings switch-to-workspace-5 ['disabled']
org.gnome.desktop.wm.keybindings switch-to-workspace-8 ['disabled']
org.gnome.desktop.wm.keybindings switch-to-workspace-9 ['disabled']
org.gnome.desktop.wm.keybindings switch-to-workspace-6 ['disabled']
org.gnome.desktop.wm.keybindings switch-to-workspace-10 ['disabled']
org.gnome.desktop.wm.keybindings switch-to-workspace-11 ['disabled']
org.gnome.desktop.wm.keybindings switch-to-workspace-12 ['disabled']
org.gnome.desktop.wm.keybindings switch-to-workspace-left ['<Control><Alt>Left']
org.gnome.desktop.wm.keybindings switch-to-workspace-last ['<Super>End']
org.gnome.desktop.wm.keybindings switch-to-workspace-up ['<Control><Alt>Up']
org.gnome.desktop.wm.keybindings switch-to-workspace-right ['<Control><Alt>Right']

No setting to change that behaviour...

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.