0

I have Windows 7 x64 bits on my TravelMate P446-M laptop. The laptop comes with HDD that is already partitioned into two NTFS partitions around 250 GBytes and one hidden partition for recovery. I installed Ubuntu LTS 16.04 using Flash Memory. During the installation, I re-partitioned the second 250 Gbytes partition into the following three partitions:

  1. 50 Gbytes to mount the root '/' as ext4
  2. 190 Gbytes to mount '/home' as ext4.
  3. A partition for swap around 12 Gbytes.

I selected the place of the boot loader to be the whole hard-disk i.e. did not specify any partition. After I finished the installation, I am not able to find Ubuntu in the boot menu not even in the boot tab of the msconfig in Windows. I tried the boot-repair tool on live Ubuntu on the Flash Memory but nothing changed.

root@ubuntu:/home/ubuntu# parted --list
Model: ATA WDC WD5000LPLX-2 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system     Name                          Flags
 1      1049kB  106MB  105MB   fat32           EFI system partition          boot, esp
 2      106MB   123MB  16.8MB                  Microsoft reserved partition  msftres
 3      123MB   231GB  231GB   ntfs            Basic data partition          msftdata
 4      231GB   232GB  524MB   ntfs            Basic data partition          hidden, diag
 5      232GB   282GB  50.0GB  ext4
 7      282GB   453GB  171GB   ext4
 8      453GB   464GB  11.0GB  linux-swap(v1)
 6      464GB   500GB  36.3GB  ntfs            Basic data partition          hidden, diag


Model: JetFlash TS2GJFV30 (scsi)
Disk /dev/sdb: 2032MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  2032MB  2031MB  primary  fat32        boot, lba

Here is the output of sudo efibootmgr -v:

ubuntu@ubuntu:~$ sudo efibootmgr -v
BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 2001,0001,2002,2003
Boot0000* Unknown Device:   HD(1,GPT,61f0988b-288d-4d52-b004-c4d38f79d407,0x800,0x32000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot0001* Windows Boot Manager  HD(1,GPT,61f0988b-288d-4d52-b004-c4d38f79d407,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0002* USB HDD: JetFlashTS2GJFV30    PciRoot(0x0)/Pci(0x1d,0x0)/USB(0,0)/USB(3,0)/HD(1,MBR,0x75,0x800,0x3c8800)RC
Boot0003* Unknown Device:   HD(1,GPT,61f0988b-288d-4d52-b004-c4d38f79d407,0x800,0x32000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot0004* Unknown Device:   HD(1,GPT,61f0988b-288d-4d52-b004-c4d38f79d407,0x800,0x32000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot0005* Unknown Device:   HD(1,GPT,61f0988b-288d-4d52-b004-c4d38f79d407,0x800,0x32000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot2001* EFI USB Device    RC
Boot2002* EFI DVD/CDROM RC
Boot2003* EFI Network   RC
  • Welcome to AskUbuntu! ;-) Boot the usb disk again, use "try ubuntu", press [Ctrl][Alt][T] to go to a terminal and type parted --list, then come back here edit your question and post the output of the command. Then leave a comment @Fabby. – Fabby Oct 28 '16 at 22:19
  • @Fabby, here is the output of parted – IoT Oct 28 '16 at 23:24
  • That's an UEFI system. Did you install in UEFI mode? If you don't know, Use the boot-repair CD and post its log to paste.ubuntu.com and leave another @fabby Hopefully someone else will pick this up as I've got a 7h drive of me and going to sleep now. – Fabby Oct 28 '16 at 23:36
  • @Fabby I already tried boot-repair and it always give successful message at the end but nothing changes. I even follow the instruction at the end of the report but nothing happens. Here is the log output – IoT Oct 28 '16 at 23:51
  • looks cool to me too, so I left a note for our local UEFI and hard disk guru... He'll be along in a few hours. – Fabby Oct 29 '16 at 0:07
0

Your partition table looks OK, and your EFI System Partition (ESP) has boot loaders for both Windows and Ubuntu. Your Boot Repair output, though, lacks information from sudo efibootmgr -v, which reveals the computer's NVRAM boot manager entries. My suspicion is that your firmware is defective and is forgetting or ignoring these entries. This is a problem that crops up repeatedly, particularly with some brands. See, for instance:

  • I edited my question and added the output of your requested command. – IoT Nov 2 '16 at 13:43
  • I disabled secure boot in the BIOS and did boot-repair again. Here is the paste2.org/MP5mZL1x – IoT Nov 2 '16 at 13:59
0

I managed eventually to fix the problem. I did a clean installation of Windows 10 x64 having UEFI boot mode and secure boot disabled. Then, I installed Linux Ubuntu 16.04.1. Finally, in Windows I run the following command in the command promt:

bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

After that I started to see the Grub Boot Menu and be able to select Ubuntu or Windows. However, for the original settings with Windows 7 x64 with boot legacy mode and Ubuntu 16.04.1, I was not able to show the Grub Menu.

  • You have an Acer which has unique requirements for setting UEFI password & enabling "trust" from UEFI on Ubuntu/grub .efi files in ESP from UEFI. Also make sure you have newest UEFI from Acer. Some older threads suggest downgrading to older UEFI, but newer ones say newest UEFI from Acer works. Acer Aspire E15 will not dual boot, many details Trust settings in step 35 askubuntu.com/questions/627416/… and:Acer Very latest UEFI/BIOS works, downgrade not required: ubuntuforums.org/… – oldfred Nov 2 '16 at 16:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.