after much research ang googling, my web cam is still not recognized. In the time of Ubuntu 11.04 it was working fine. I did a fresh install of 11.10 and not more web cam. All the cheese and camera monotor and V4L tests and all failes with "cannot connect to /dev/video0 or equivalent.

The output of 'lsusb' shows the webcam

Bus 001 Device 002: ID 05a9:2640 OmniVision Technologies, Inc. OV2640 Webcam

What I noticed is that neither /dev/v4l nor /dev/video* exists.

If I re-install the v4l package all the /dev/video* are created, but no /dev/v4l

If I reboot the /dev/video* are NOT created.

I think the trouble is that the device are not created at boot time.

I have a DELL Inspiron 1525 and until this fresh install the web cam worked fine.

Can somebody help ?

2 Answers 2


I have the exact same webcam; my computer is a Dell XPS M1530. For quite some time I have not been able to use my webcam with the Video4Linux drivers, which I wanted to because they seem to have more active development.

I found out that this webcam is supported by another driver, UVC Video. There is a list of the supported devices here, and it includes the webcam you mention.

Use your webcam with UVC Video

Each of the commands shown here you have to run in a terminal window.

  1. Check if you have the driver by running $ sudo modprobe uvcvideo.

  2. Check if other drivers are loaded, that are conflicting with uvcvideo: Run the following commands:

    • $ sudo modprobe -r videodev
    • $ sudo modprobe -r v4lTab (repeat this command for every entry listed when you press Tab).
  3. Unload and load back again uvcvideo by running:
    $ sudo modprobe -r uvcvideo && sudo modprobe uvcvideo.

  4. Open Cheese or any other application that will allow you to view through your webcam to see if you are getting video.
  5. If this worked, you should blacklist videodev and make uvcvideo load everytime you boot.
    • To blacklist videodev run the following command:
      $ sudo echo blacklist videodev >> /etc/modprobe.d/blacklist-local.conf
    • To enforce the load of uvcvideo on every boot, run this other command:
      $ sudo echo uvcvideo >> /etc/modules


I only wrote this guide because this is how I got this problem fixed in my case; however, I don't know whether each of the commands I cited are mandatory or optimal.


I solved my problem.

Don't ask me how it works, but what I did is that I reinstalled medibuntu because after the upgrade it was unvalidated. And everything worked again. I did this because I noticed that I also had no more sound.

After upgrading with medibuntu both sound and webcam worked perfectly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .