61

Ok, So I've made my script, I dropped it in /etc/cron.hourly then I chmod 777 the file but it won't run (automatically). If I manually run it, it works fine. Do I need to do anything else?

  • This answer shouldn't have received that many upvotes without name of file and content. – user unknown Feb 5 '18 at 16:46
12

Why not using crontab ( /etc/crontab ) and use */1 in the hour field. I have used this to run a script every 5 min and it works well:

# m h dom mon dow user  command
* */1  * * *   user    command
| improve this answer | |
  • 6
    Using cron.daily and friends works a bit better if the machine is not running all the time, because anacron tries to approximate the right schedule whereas plain cron will just not run them if the machine is not on all night. For hourly jobs this probably doesn't matter so much. – poolie Dec 2 '10 at 0:20
  • 9
    I really appreciate the next answer, as it addresses the problem with cron.hourly, rather than finding a workaround. – tishma Jan 24 '14 at 14:24
  • 4
    This is not an answer to the question – josh123a123 Nov 16 '16 at 15:48
  • @poolie As can be seen on /etc/crontab: cron.daily, cron.weekly and cron.monthly run with anacron (if available) but hourly run-parts --report /etc/cron.hourly. – Pablo Bianchi Feb 5 '18 at 15:24
155

Entries in cron.hourly are run by the run-parts mechanism (man run-parts for more info). And run-parts is choosy about what filenames it considers valid.

For example, giving your script an extension will make it invalid and result in the job not being run. [a-zA-Z0-9_-] are the valid characters, so the '.' makes it invalid.

When adding a job to /etc/cron.hourly ( or .daily, .weekly, etc), always test afterwards that run-parts will actually run it by issuing the command:

run-parts --test /etc/cron.hourly

If by running this command it shows your file it means it worked. Otherwise, if doesn't show anything your file name is not valid.

What was the name of your script?

| improve this answer | |
  • There are two: cerebro_random_response.sh and Cerebro Temperature.sh no good? – Switchkick May 14 '11 at 0:41
  • 21
    correct, no good :) [a-zA-Z0-9_-] are the valid characters, so the '.' makes it invalid. This is what i meant above by 'giving your script an extension will make it invalid' – DaithiF May 19 '11 at 16:43
  • 11
    oMG, This just saved a huge headache. THANK YOU! giving your script an extension will make it invalid and result in the job not being run – Jonathan S. Fisher Dec 5 '13 at 22:16
  • You may also use --report to actually run the scripts. – Pablo Bianchi Feb 5 '18 at 16:24
  • 1
    Thanks for this info. My issue was that the script wasn't executable, chmod +x /etc/cron.hourly/myscript did the trick and run-parts listed it as expected. – Yvan Nov 8 '19 at 10:08
5

Your problem is probably down to the overly open permissions, which allows anybody to edit your file. Try 755 instead.

Looking in the cron entries in your syslog output should confirm this.

| improve this answer | |
5

DaithiF's answer should be the right answer.

Also, my script didn't have #!/bin/bash in the first line. Even though the script could be executed with the command line, run-parts rejected it saying "Exec format error".

Changing the file name from scriptname.sh to scriptname and adding the #!/bin/bash into first line enabled my script to run hourly.

| improve this answer | |
-1

When you run

crontab -l

is this task on the list?

if not, add it

crontab -e

add this line

0 * * * * yourScript

if it is in this list, try to add the path of programing language to the top of your script

Example:

bash: #!/bin/bash

This 2 things always solved my problems :)

| improve this answer | |
  • Done it all and the script is good, it works like a charm. It's in the crontab list too but no hourly task runs. Thanks anyway :( – Switchkick Oct 20 '10 at 8:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.