2

I upgraded to Ubuntu GNOME 16.10 from 16.04. I have an HP Laptop with a touchpad. Previously you could scroll using the right hand edge of the touchpad, but no longer. I can only use two-finger scroll, and I don't like it, it also tends to not work that well.

I tried similar instructions to this answer and this one too, but the "touchpad" option is missing in dconf-editor under the following tree:

org > gnome > settings-daemon > peripherals > touchpad

I have installed gnome-tweak-tool for Gnome 3.20 (using these instructions), but it has no options available either.

Any ideas how to get scrolling using the edge of the touchpad?

UPDATE 1:

I looked under

org > gnome > desktop > peripherals > touchpad

and the settings were available. But the scrolling parameter was already set to edge-scrolling (see image below), but it does not seem to work.

enter image description here

UPDATE 2: I created a new user. Because they would have fresh settings and would show that my settings may be slightly corrupt. But the new user has the same issue.

  • don't use 16.10 but maybe have a look in /org/gnome/desktop/peripherals/touchpad and /mouse – doug Oct 28 '16 at 0:42
  • @doug thanks, I looked under /org/gnome/desktop/peripherals/touchpad and mouse, and I found the settings, but that did not help. I have updated the question with a screenshot. And I like near-bleeding-edge and this is my only issue with 16.10 at the moment. – psiphi75 Oct 28 '16 at 3:07
  • I see that ubuntu-gnome 16.10 is using xserver-xorg-input-libinput. Apparently those dconf options won't apply to libinput. If that's the case you can either try installing xserver-xorg-input-synaptics & removing xserver-xorg-input-libinput, after a reboot edge would likely work. Otherwise you'd need to research how to affect changes to libinput, I looked at that some time ago but atm don't remember. (creating a file somewhere... maybe – doug Oct 28 '16 at 22:53
  • 1
    maybe look here - wiki.archlinux.org/index.php/Libinput though also read here - ask.fedoraproject.org/en/question/89443/… – doug Oct 28 '16 at 22:56
  • @doug, awesome, and thanks a lot. That last link you provided did the trick. If you write up the answer I will accept it. I used the exact steps as on the ask Fedora page. – psiphi75 Oct 29 '16 at 0:04
2

Libinput on X11 workaround. This was taken directly from ask.fedoraproject.org. This is what made it work for my Ubuntu GNOME.

There is a workaround for libinpunt on X11:

1) Determine ID of your touchpad, for me it was the SynPS/2 Synaptics TouchPad with id of 11:

xinput list

2) Create desktop file in ~/.local/share/applications named edge-scroll-workaround.desktop. This creates the edge-scroll-workaround application.

vim ~/.local/share/applications/edge-scroll-workaround.desktop

3) Place here this code in the edge-scroll-workaround.desktop file:

[Desktop Entry]
Name=Edge scroll workaround
Exec=/usr/bin/xinput set-prop **ID OF TOUCHPAD** "libinput Scroll Method Enabled" 0, 1, 0
Type=Application

4) In Tweak Tool (available in gnome-tweak-tool package) go to Startup Applications, click on + and in list find Edge scroll workaround.

5) Run edge-scroll-workaround.desktop, I do this by clicking the Super key and typing edge- and the application should appear. Logout/login or restart and that's it.

0

Go to settings and go to this section:

Org > Gnome > Desktop > Peripherals > Touchpad

Once you are there, change natural-scroll to false.

  • Unfortunately this does not work for me. – psiphi75 Jan 8 '17 at 8:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.