55

Just wondering if there a way to temporarily disable PulseAudio as I am trying to run a specific Wine game (Left 4 Dead 2) and it makes the game crash occasionally.

If I kill the process it automatically comes back up. Any suggestions?

36

In my case, I was unable to stop pulseaudio since it was being restarted automatically by systemctl.

The proper way to stop pulseaudio, in that case is:

systemctl --user stop pulseaudio.socket
systemctl --user stop pulseaudio.service

To start it again, you can use:

systemctl --user start pulseaudio.socket
systemctl --user start pulseaudio.service
4
  • 1
    It could be that it's not being managed by systemctl. In that case, to stop pulseaudio, you should just pulseaudio -k.
    – user156516
    Dec 12 '18 at 0:19
  • 1
    My mistake, I was using service instead of systemctl. Dec 12 '18 at 1:43
  • systemctl accepts multiple arguments, so these can also be run as a single command, eg. systemctl --user stop pulseaudio.socket pulseaudio.service Apr 13 at 15:30
  • If you are using a shell with brace expansion, this can be shortened to be easier to type: systemctl --user stop pulseaudio.{socket,service} and systemctl --user start pulseaudio.{socket,service}
    – SO Stinks
    Sep 2 at 5:25
34

You can use pasuspender. Try prefixing your wine command with it.

pasuspender -- wine path/to/file.exe
3
  • How do I reenable PulseAudio after disabling it? I have no sound after running this, except in the program I run with pasuspender (chuck in my case), even after exiting said program (chuck). Audio does work as normal after I restart my computer. Is my experience what is expected?
    – jyoungdev
    May 11 '15 at 1:54
  • I answered my own question. From wiki.debian.org/…: "While you run pasuspender, other applications won't be able to use PulseAudio. When you quit the application, the default behaviour of PulseAudio will be restored automatically." So I have a special problem tangential to the original question.
    – jyoungdev
    May 11 '15 at 1:57
  • prefixing pasuspender to qjackctl (pasuspender qjackctl) solved ages of problems for me!!! thank you so much Oct 6 '15 at 17:17
32

In /etc/pulse/client.conf, you can uncomment the line autospawn=yes and replace the yes with a "no". Of course this should be possible to set this in .pulse directory in your home directory.

A cleaner way to do this would be to create a client.conf in your .pulse dir in ~ and put the line "autospawn=no" in it. It would be good to turn back on autospawn after you have done what you need to do.

3
  • 1
    Or, edcould be used to change the config before running the game, and change it back afterwards.
    – nanofarad
    Jul 19 '12 at 15:33
  • second line put that you said, and first line just put: .include /etc/pulse/client.conf Oct 15 '16 at 2:23
  • 2
    Neither this or creating a .config/pulse/client.conf in my homedir with autospawn=no works for me. Pulseaudio continues to start on boot - Ubuntu 19.10
    – timbo
    Nov 19 '19 at 20:15
23

I use the script:

#!/bin/sh
echo autospawn = no >> "$HOME/.config/pulse/client.conf"
pulseaudio --kill
sed -i '/\<autospawn\>/d' "$HOME/.config/pulse/client.conf"

Then play the game, then re-enable PA:

pulseaudio --start

Works on Xubuntu 13.10. Replace ".config/pulse" with ".pulse" in the script if it doesn't work (usually on old *buntues)

4
  • Very elegant approach. Aug 26 '14 at 11:44
  • 3
    Useless if you already have a client.conf and end up deleting it.
    – Ken Sharp
    Apr 7 '15 at 3:19
  • 1
    Then replace the rm with sed -i '/\<autospawn\>/d' $HOME/.config/pulse/client.conf...
    – bufh
    Jan 24 at 9:25
  • 1
    Works beautifully without a system restart. Very appreciated, including @bufh's addition.
    – david
    May 6 at 19:38
5

Alt+F2 type pactl exit

stops all pulseaudio processes. You can enter

Alt+F2 type pulseaudio

to start it again. Unfortunately, some programs doesn't seem to sound anymore, after that. Still looking for a way to reactivate pulse without reboot…

2
  • 7
    pactl exit does not stop pulseaudio completely on my machine, it is immediately restarted (just like with pulseaudio -k). Aug 15 '14 at 13:10
  • pactl exit worked for me. With pulseaudio -k it restarted automatically even though I had autorespawn disabled.
    – cbix
    Jan 31 '17 at 19:48
0

Try this Ubuntu Tips. It works fine on my Ubuntu 12.04 LTS.

Ubuntu Tip: Turning PulseAudio On and Off

0
-1

What I did.... stopped it from respawning because it couldn't find it....... right click the /etc folder in the file browser (open as root) create a new folder called pulseoff, then move the pulse folder into it (drag and drop). The system doesn't have the command to look there for it. If you want to start it again, cut it from the pulseoff folder, go up a step to the /etc folder and paste it there...... Some people like to make it out to be harder than it really is with editing files and stuff and mostly those edits don't work I tried them. Do it the easy way. I restarted the machine and checked the system monitor before posting this, pulseaudio is not running and sucking up memory.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.