1

I installed Ubuntu 16.04 LTS a few days ago on a brand new SSD, which was empty (sda), and kept the Windows 7 install which is on a separate SSD (sdb). Grub was installed properly (I guess on sda?) and after installing Ubuntu, I could select what system to start, from the grub menu. I tried that right after installation, and it did work fine.

But this morning, when I tried to restart Windows from the grub menu, I got the following error message:

error: no such device: 2844473F44470F4E.
Setting partition type to 0x7

Press any key to continue...

Now I cannot start my Windows system anymore. Any idea what has gone wrong, and how I could fix that?

Additional info that may help:

The initial fstab after Ubuntu install was:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=27e8f423-5046-4bf4-8bf6-3ca19a440e9c /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=a123385a-2e28-45da-a699-574f26e43b54 none            swap    sw              0       0

which I changed (to add a network drive) into:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=27e8f423-5046-4bf4-8bf6-3ca19a440e9c /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=a123385a-2e28-45da-a699-574f26e43b54 none            swap    sw              0       0
# added on october 25, 2016, following instructions @ http://ubuntuhandbook.org/index.php/2014/08/map-network-drive-onto-ubuntu-14-04/
//192.168.0.1/data                         /media/z        cifs    credentials=/home/jfs/.smbcredentials,iocharset=utf8,gid=1000,uid=1000,file_mode=0777,dir_mode=0777   0       0

After trying boot-repair (see comments, it did not help so far), the report can be found at: http://paste2.org/AVeadskx

  • boot into ubuntu and run from terminal sudo update-grub. Let us know, if that helped – Michal Polovka Oct 27 '16 at 13:02
  • Thanks for the advice. I just tried, unfortunately, it didn't do much, I still get the same error... – jfs Oct 27 '16 at 13:20
  • OK, another possibility is to use boot-repair. Visit this page and install boot-repair in ubuntu help.ubuntu.com/community/Boot-Repair . The launch it a do Recommended repair – Michal Polovka Oct 27 '16 at 13:35
  • I tried Boot-Repair, it ran ok. After restarting I have some grub entries which have disappeared (memory test, etc.), I can still boot linux, but I still get the same error when trying to boot windows... – jfs Oct 27 '16 at 14:01
  • Very strange. Have you done any changes to fstab, or renamed your partitions via Disks or gparted? – Michal Polovka Oct 27 '16 at 14:08
2

FYI, I fixed my problem by fixing the boot sector of the drive on which Windows was installed (sdb). For that I used a "Windows repair disk".

I guess that the issue came from Grub having changed something on my Windows drive (maybe during grub update) but not sure...

Step by step instructions:

  1. I got a repair disk for my version of Windows (in my case 7, 64 bits). If you have one, use it. If you don't, you can use any Windows 7 computer to burn one (see e.g. https://www.lifewire.com/how-to-create-a-windows-7-system-repair-disc-2626301)
  2. I disconnected my Linux drive (sda), to prevent any writing on it during the process.
  3. I configured the BIOS to start on the CD drive.
  4. I booted on the repair disk, and chose the option to start a "dos" command prompt.
  5. I ran the two commands:

    bootrec /fixmbr
    bootrec /fixboot
    
  6. I checked the BIOS to make sure that the computer would boot on sda first (linux drive with Grub), and sdb with lower priority (windows).

After that, I reconnected the Linux drive. Now I can use Grub to boot on the two systems. I also configured Linux to mount /dev/sdb read only to prevent Linux from writing the windows drive in the future.

1

Try to remove the '//192.168.0.1/data /media/z cifs credentials=/home/jfs/.smbcredentials,iocharset=utf8,gid=100‌​0,uid=1000,file_mode‌​=0777,dir_mode=0777 0 0' line and restart.

  • 1
    Hi, I already tried that, and it did not fix the issue – jfs Oct 28 '16 at 11:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.