10

I'm following instructions from here (see Ubuntu section). It says me to do

sudo add-apt-repository ppa:staticfloat/juliareleases
sudo add-apt-repository ppa:staticfloat/julia-deps
sudo apt-get update

But then the command

sudo apt-get install julia

Gives me

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 julia : Depends: libcholmod1.7.1 but it is not installable or
              libcholmod2.1.2 but it is not installable or
              libcholmod3.0.6 but it is not installable
     Depends: libumfpack5.4.0 but it is not installable or
              libumfpack5.6.2 but it is not installable or
              libumfpack5.7.1 but it is not installable
E: Unable to correct problems, you have held broken packages.

I am using Xubuntu 16.10.

Can you please help me to understand what is going on and how to solve it?

1
  • For the record, Julia is available in official Ubuntu repositories, there's no need to add external PPA unless you rely on the newest version of the language – Sergiy Kolodyazhnyy May 22 '18 at 9:39
6

For future users: get the newer version/a working link from https://julialang.org/downloads/

# go to your user folder
cd ~
# get julia
wget https://julialang-s3.julialang.org/bin/linux/x64/1.3/julia-1.3.0-linux-x86_64.tar.gz
# extract the file (eXtract File as options)
tar xf julia-1.3.0-linux-x86_64.tar.gz
# Create a shortcut (a soft link) that's places in a globally accessible folder
sudo ln -s ~/julia-1.3.0/bin/julia /usr/local/bin/julia

Now you can run julia anywhere.

1

It seems like you have broken packages. To fix the problem, you might want to try entering this into the terminal:

sudo sh -c "apt-get update;apt-get dist-upgrade;apt-get autoremove;apt-get autoclean"

Also enter this into the terminal:

sudo apt --fix-broken install

This should fix up your broken packages. Now try installing Julia again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.