After a recent upgrade it seems that I have removed network-manager-gnome, or did upgrade -f did it, so I do not see the network indicator in the panel. Network is active, both wireless and local.

I have tried:

  1. nm-applet, it's not installed. If I try to install it by installing network-manager-gnome I receive:

    The following packages have unmet dependencies: 
    network-manager-gnome : Depends: default-dbus-session-bus but it is not installable or dbus-session-bus but it is not installable
                            Recommends: mobile-broadband-provider-info but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
  2. Restarting the service sudo service network-manager restart just restarts it to make it work again, but again, no indicator.

Edit (Requested Outputs):

  • Output of cat nm-applet:

    [Desktop Entry]
    Comment=Manage your network connections
  • locate nm-applet indicates:

    gaj@gaj-Lenovo-Z51-70:~$ locate nm-applet
  • If I try to install network-manager-gnome using using aptitude i get:

    The following NEW packages will be installed:
    0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Need to get 910 kB of archives. After unpacking 6049 kB will be used.
    The following packages have unmet dependencies:
     network-manager-gnome : Depends: default-dbus-session-bus which is a virtual package and is not provided by any available package.
                                      dbus-session-bus which is a virtual package and is not provided by any available package.
    The following actions will resolve these dependencies:
         Keep the following packages at their current version:
    1)     network-manager-gnome [Not Installed]              
    Accept this solution? [Y/n/q/?] y


    Starting pkgProblemResolver with broken count: 1
    Starting 2 pkgProblemResolver with broken count: 1
    Investigating (0) network-manager-gnome [ amd64 ] < none -> 1.2.4-0ubuntu2~ubuntu16.04.1~ppa1 > ( gnome )
    Broken network-manager-gnome:amd64 Depends on default-dbus-session-bus [ amd64 ] < none > ( none )
    Broken network-manager-gnome:amd64 Depends on dbus-session-bus [ amd64 ] < none > ( none )
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    The following packages have unmet dependencies:
     network-manager-gnome : Depends: default-dbus-session-bus but it is not installable or
                                      dbus-session-bus but it is not installable
    E: Unable to correct problems, you have held broken packages.
  • Please edit your post to include the output of cat /etc/xdg/autostart/nm-applet.desktop
    – Elder Geek
    Oct 28, 2016 at 23:19
  • Also edit to indicate what flavor of Ubuntu you are running. Thank you for helping us help you!
    – Elder Geek
    Oct 28, 2016 at 23:27
  • It needs close examining of the package status. If you have time, can you visit AskUbuntu General Chat room and ping me (@Anwar). I can try helping you. Basically You need to pinpoint what exactly was causing the unmet dependency errors
    – Anwar
    Oct 29, 2016 at 17:37
  • i just did, but it doesn't seem to be a problem with dependecies, rather just the problem with starting the indicator. maybe the name or the output has changed, so it won't start. i edited my question with the output you asked for.
    – Mookey
    Oct 29, 2016 at 19:02
  • 1
    @Mookey, Official network-manager-gnome does not have dependency to dbus-session-bus, you may have bad copy from a ppa. Could you add output of apt-cache policy network-manager-gnome; apt-cache show network-manager-gnome . you may post them to paste.ubuntu.com as question became long.
    – user.dz
    Oct 30, 2016 at 22:10

3 Answers 3

  1. Just for any case start with updating the package list.

    sudo apt-get update

    Be aware that anything further could have some minor possibility of removing an important network package, and you could got in a complicated non-network situation. So be careful and do not delete anything before you read the rest of the steps.

  2. Use aptitude if possible.

    sudo aptitude

    (if it is installed). It is really more aggressive in resolving dependencies than apt-get or perhaps whatever GUI you're using. Have a look at the manpage, but for a quick start you can see all the broken packages by pressing "b" (which stands for broken) few times. Then just hit once "g" (which stands for go) and look at the package tree about the suggested solutions. If the solution is not deleting the whole system :) (more than a few debs) you can apply it with the second "g".

  3. If you do not have aptitude or the aforementioned repair did not succeed, repair all broken packages by:

    sudo apt-get -f install
  4. If you still had no luck, you need to fix it manually with some more time spent on solving the problem. In this case look first at the hold packages:

    apt-mark showhold 


    dpkg --get-selections | grep hold

    then look at the broken packages:

    dpkg -l | grep ^..r 

    and then unhold the broken one that is making you mad:

    sudo apt-mark unhold package_name

    and try

    sudo apt-get -f install


Then finally you can try to install aptitude and use it for installing the package you need. If this is not successful, add to your question the list of the hold and broken packages as you may have really broken dependencies.

EDITED after extra information received from the question author

It seem that you have some PPA installed which gives higher priority to network-manager-gnome package with version 1.2.4-0ubuntu2~ubuntu16.04.1~ppa1 over the latest stable at the moment (in 16.04) 1.2.0-0ubuntu0.16.04.4. The newer package comes probably from some gnome-backport repository like gnome-backport repository like this.

Two ways to continue...

  1. Revert the stable (for 16.04) version of Gnome
  2. Find the missing packages from any other PPA

For scenario 1: My next suggestion is to start aptitude in interactive mode by running sudo aptitude then press slash ( "/" ) for search and write in the search field network-manager-gnome and enter. When the package is selected open it with enter and go with the arrows/pgdown to the bottom of the info page. There you can chose to install the official version "1.2.0-0ubuntu0.16.04.4" - select it and press plus (+). This will trigger the package dependency resolver of aptitude and it will try to give you a resolution. In case the hedaer goes red, this means there are some broken dependences - press several times "b" to check them...

Unfortunately the resolution most probably will be deleting all backported Gnome staff ... If you can stand it - do it. Then try to install via aptitude any further package to see in advance in what mess you can get...

For scenario 2: We need first to know the backport repository thet you're using... could be some other than this, so as suggested in the comment discussion - give the output of

egrep -v '^#|^ $' /etc/apt/sources.list /etc/apt/sources.list.d/ 


egrep Pin-Priority /etc/apt/preferences /etc/apt/preferences.d/*
  • aptitude does not reveal any upgradable packages or unmet dependecies. everything's working fine, and there's nothing to fix through aptitude. just no applet.
    – Mookey
    Oct 29, 2016 at 18:53
  • @Mookey, then "sudo aptitude install network-manager-gnome" ? What is the output? Oct 29, 2016 at 19:56
  • I just edited it.
    – Mookey
    Oct 30, 2016 at 20:19
  • So... seems that you have some PPA with higher priority. Shame on me that haven't started asking this from the beginning... So can you please give us the output from: " egrep -v '^#|^ $' /etc/apt/sources.list /etc/apt/sources.list.d/ " and " Oct 30, 2016 at 21:47
  • 1
    @user.dz, suggest more clever way than me for finding the source of your "backport" PPA. commenting here as I do not have enough reputation to do it in the question itself. Oct 30, 2016 at 22:56

your locate command indicates that you are missing a great deal of content from the usr/share/nm-applet/ directory. the content you are missing can be found in the network-manager-gnome_1.1.93-1ubuntu1_amd64.deb package which can be found here. If you are unable to install it by normal means dpkg has a big hammer for situations such as this and issuing the command sudo dpkg -i --force-downgrade network-manager-gnome_1.1.93-1ubuntu1_amd64.deb

If you have a current backup For an even bigger hammer you can use the --force-depends or --force-all switches

I'm not kidding about the backup. More information is available regarding dpkg force options with the command: dpkg --force-help which I have replicated below for your convenience

dpkg forcing options - control behaviour when problems found:
  warn but continue:  --force-<thing>,<thing>,...
  stop with error:    --refuse-<thing>,<thing>,... | --no-force-<thing>,...
 Forcing things:
  [!] all                Set all force options
  [*] downgrade          Replace a package with a lower version
      configure-any      Configure any package which may help this one
      hold               Process incidental packages even when on hold
      not-root           Try to (de)install things even when not root
      bad-path           PATH is missing important programs, problems likely
      bad-verify         Install a package even if it fails authenticity check
      bad-version        Process even packages with wrong versions
      overwrite          Overwrite a file from one package with another
      overwrite-diverted Overwrite a diverted file with an undiverted version
  [!] overwrite-dir      Overwrite one package's directory with another's file
  [!] unsafe-io          Do not perform safe I/O operations when unpacking
  [!] confnew            Always use the new config files, don't prompt
  [!] confold            Always use the old config files, don't prompt
  [!] confdef            Use the default option for new config files if one
                         is available, don't prompt. If no default can be found,
                         you will be prompted unless one of the confold or
                         confnew options is also given
  [!] confmiss           Always install missing config files
  [!] confask            Offer to replace config files with no new versions
  [!] architecture       Process even packages with wrong or no architecture
  [!] breaks             Install even if it would break another package
  [!] conflicts          Allow installation of conflicting packages
  [!] depends            Turn all dependency problems into warnings
  [!] depends-version    Turn dependency version problems into warnings
  [!] remove-reinstreq   Remove packages which require installation
  [!] remove-essential   Remove an essential package

WARNING - use of options marked [!] can seriously damage your installation.
Forcing options marked [*] are enabled by default.

It appears that you obtained the version you have installed from ppa:vascofalves/gnome-backports I recommend you remove this PPA from your sources.list as it's clearly stated in the description that

PPA description

Backports of GNOME packages. This is for my personal use. Don't expect anything here to work properly.



How can PPAs be removed?



This was a problem that was solved by using aptitude to reinstall or install network-manager-gnome, upon which I was informed that dependencies could either be resolved, or not change anything. Solving dependecies solved the problem (degraded them).

  • "degraded them" so you were having some package from other repo then official Ubuntu releases . Could you share the list of those packages, you may get them from APT history.
    – user.dz
    Dec 24, 2016 at 23:18
  • 1
    – Mookey
    Dec 25, 2016 at 9:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.