0

I have an old HP Proliant. I've got a dual-boot setup with Windows 7. Windows 7 tells me that I've got a Generic Non-PnP Monitor on Standard VGA Graphics adapter, and the display settings are set to 1024x768, which looks nice.

I've tried Xubuntu and Lubuntu, but I can't change my monitor settings: it's stuck on 640x480 and everything is too large to fit on the screen.

I've tried nomodeset in the Grub settings but that didn't help. I've seen several pieces of advice here, but they seem to deal with Nvidia adapters. What can I do? I can't use this machine like this!

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 640 x 480, maximum 640 x 480
default connected 640x480+0+0 0mm x 0mm
   640x480       73.00* 

lspci
00:00.0 Host bridge: Intel Corporation E7220/E7221 Memory Controller Hub (rev 05)
00:01.0 PCI bridge: Intel Corporation E7220/E7221 PCI Express Root Port (rev 05)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 03)
00:1d.0 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
00:1d.1 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
00:1d.2 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
00:1d.3 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
00:1d.7 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d3)
00:1f.0 ISA bridge: Intel Corporation 82801FB/FR (ICH6/ICH6R) LPC Interface Bridge (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801FR/FRW (ICH6R/ICH6RW) SATA Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 03)
01:00.0 PCI bridge: Intel Corporation 6702PXH PCI Express-to-PCI Bridge A (rev 09)
01:00.1 PIC: Intel Corporation 6700/6702PXH I/OxAPIC Interrupt Controller A (rev 09)
02:01.0 Serial controller: MosChip Semiconductor Technology Ltd. PCI 9835 Multi-I/O Controller (rev 01)
0a:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8169 PCI Gigabit Ethernet Controller (rev 10)
0a:01.0 Ethernet controller: Intel Corporation 82541GI Gigabit Ethernet Controller (rev 05)
0a:03.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Rage XL PCI (rev 27)

It looks fine while installing... the splash and information screens are correct. It's only once it wants my login that the display is about 2 times too large for the screen.

Also... I seem to remember having this problem once before with this pc. Of course, I have no idea how I managed to fix it.

  • try issuing the command xrandr in a terminal and edit your question to include the output. This will give some insight into your video outputs and available modes, and may allow someone to post a solution. – Organic Marble Oct 26 '16 at 13:59
  • Please edit your question to include the output of lspci. – Android Dev Oct 26 '16 at 14:46
  • Hmm, your xrandr output is not showing any video outputs. Usually you see VGA-0 or similar. This is deeper than my knowledge really goes but I suspect you are missing a driver. What does "Additional Drivers" show? – Organic Marble Oct 26 '16 at 15:01
0

I found a way to fix this:

  • 1st install Ubuntu 14.04 (I tried this using Lubuntu and Xubuntu). The screen display will be 640x480.
  • ignore notifications of new Ubuntu versions.
  • set "notify me of a new Ubuntu version" to "Never" (Software & Updates)
  • from the command prompt, run sudo apt-get update sudo apt-get upgrade sudo apt-get dist-upgrade (apt-get-update will install the necessary display driver)
  • reboot: the display will now be correct.
  • back into Software & Updates: change "notify me of a new Ubuntu release" to "For Long-term support versions"
  • from the command prompt: sudo do-release-upgrade (this took me about 2 hours)

My old VGA monitor now works correctly with Ubuntu 16.04

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.