0

3 days ago I updated Ubuntu and restarted.

My Java process, that launch phpstorm, go up to 600% CPU usage and kills my pc in about 20 second.

I was on phpstorm 8 with Java openJDK 8.

As test I tried to swap to the oracle version but same result!

Then I manually removed phpstorm from my system and updated it to the last version, the 10th.

Still overheating with no chance to work on it! any suggestion?

My system is:

Description: Ubuntu 16.04.1 LTS Release: 16.04 Codename: xenial

uname -r ----> 4.4.0-45-generic

cat /proc/cpuinfo processor : 0 vendor_id : GenuineIntel cpu family : 6 model : 42 model name : Intel(R) Core(TM) i7-2630QM CPU @ 2.00GHz stepping : 7 microcode : 0x18 cpu MHz : 832.421 cache size : 6144 KB physical id : 0 siblings : 8 core id : 0 cpu cores : 4

     natty@natty-RC730:~$ cpupower frequency-info
    analyzing CPU 0:
      driver: intel_pstate
      CPUs which run at the same hardware frequency: 0
      CPUs which need to have their frequency coordinated by software: 0
      maximum transition latency: 0.97 ms.
      hardware limits: 800 MHz - 2.90 GHz
      available cpufreq governors: performance, powersave
      current policy: frequency should be within 800 MHz and 2.90 GHz.
                      The governor "powersave" may decide which speed to use
                      within this range.

  current CPU frequency is 868 MHz.
  boost state support:
    Supported: yes
    Active: yes
    25500 MHz max turbo 4 active cores
    25500 MHz max turbo 3 active cores
    25500 MHz max turbo 2 active cores
    25500 MHz max turbo 1 active cores

Edit from comments: I still get the following error:

 Oct 26 14:18:34 natty-RC730 kernel: [11779.535501] thermal thermal_zone0: critical temperature reached(98 C),shutting down Oct 26 14:18:35 natty-RC730 kernel: [11780.538680] thermal thermal_zone0: critical temperature reached(98 C),shutting down Oct 26 14:18:36 natty-RC730 kernel: [11781.549083] thermal thermal_zone0: critical temperature reached(98 C),shutting down
  • Please edit additional information into your post. What is the output of cpupower frequency-info – Elder Geek Oct 26 '16 at 14:50
  • 1
    When did you last clean the dust out of your laptop? – Elder Geek Oct 26 '16 at 20:37
  • 2
    Computer's aren't supposed to crash no matter how hard you hammer their CPU. This sounds like a hardware issue, i. e. a faulty or dusty cooling system. – David Foerster Oct 27 '16 at 11:39
0

This should not be possible provide your system is well maintained. The i7-2630QM CPU has Thermal Monitoring Technologies. this being the case, If the CPU is truly overheating (Max temp 100C) then the CPU must be faulty as it's designed to downclock and continue working if it gets hot.

Thermal Monitoring Technologies protect the processor package and the system from thermal failure through several thermal management features. An on-die Digital Thermal Sensor (DTS) detects the core's temperature, and the thermal management features reduce package power consumption and thereby temperature when required in order to remain within normal operating limits

EDIT:

Since you are using the intel_pstate driver and it doesn't appear to be working properly for you you could try disabling it and using acpi frequency control instead as described in this answer. You could also install the indicator-cpufreq package and adjust clock rates manually. Note that changing to acpi frequency control will typically provide more choices for indicator-cpufreq than the intel-pstate driver.

If your system isn't well maintained, it could be packed with dust, the cooling fan may be failing or have failed. (None of us work well when we can't breathe.) If this is the problem you'll find some options here

| improve this answer | |
  • but its happen! how can i solve this? cheers – JahStation Oct 26 '16 at 13:33
  • You might find this post educational: askubuntu.com/questions/457597/… – Elder Geek Oct 26 '16 at 13:46
  • thanks a lot, even for editing my bad eng! ill read it carefully...but to me is java/update that start to make me mad! – JahStation Oct 26 '16 at 13:49
  • 1
    @Fabby Could be that the vents are packed with dust, cooling fan has failed, etc. – Elder Geek Oct 26 '16 at 20:32
  • 1
    My idea exactly. – Fabby Oct 26 '16 at 20:34
0

the things is not solved, but a fresh install of 16.04 with updated driver now not made the temperature so critical... there was no dust in the fan, the problem is still here related to how phpstorm use to "indexing" files and folder... java still runs on 600% and over! thanks for all inputs!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.