0

I've recently installed new distribution (ubuntu 16.04, before it was ubuntu 14.04). Before installation I've copied my data on external hdd. When I was trying to copy it back, I was not able to access it. It seems that the file system (ext4) is damaged. I was able to see it with fdisk -l commnad but not to mount it. I've created mounting point in /media named external

I've run sudo mount /dev/sdb1 /media/external

The output is:

 mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
        missing codepage or helper program, or other error

      In some cases useful info is found in syslog - try
      dmesg | tail or so.

I've tried mount -t ext4 /dev/sdb1 /media/external

Output:

mount: special device /dev/sdb1 does not exist
maria@maria-Vostro-3360:/media$ 

I was also trying to boot the computer on live ubuntu 14.04, the system which was installed when I was copying the data on the external disc, but it didn't help.

Gparted shows unknown file system and under the details there is following:

Gparted

I've run testdisk. I'm not sure if I've done it correctly (for exemple I don't know if I should choose no partitionned or there was one partition on my disc. I've choose the default options, i.e. partitioned, type - Linux. The result of deep search was"

Disk /dev/sdb - 320 GB / 298 GiB - CHS 38913 255 63
     Partition               Start        End    Size in sectors
 D Linux                    0  32 33 38913  70  5  625139712
 D Linux                 1215 170 44 38913  70  5  605612032
 D Linux                 1490 100 19 38913  70  5  601198592
 D Linux                19611 118 28 25015 239 56   86822912

Since it seems the filesystem is damaged I wanted to run fsck. I've run sudo fsck -r /dev/sdb1 and I got this:

fsck from util-linux 2.27.1
e2fsck 1.42.13 (17-May-2015)
ext2fs_open2: Bad magic number in super-block
fsck.ext2: Superblock invalid, trying backup blocks...
Superblock has an invalid journal (inode 8).
Clear<y>? 

Since I don't understand really what I am doing, I typed no, I don't want to mess it up more and loose my data defenitly. The output was:

fsck.ext2: Illegal inode number while checking ext3 journal for /dev/sdb1

/dev/sdb1: ***** FILE SYSTEM WAS MODIFIED *****

/dev/sdb1: ********** WARNING: Filesystem still has errors **********

/dev/sdb1: status 12, rss 3040, real 816.797699, user 0.004000, sys 0.000000

UPDATE: In testdisk I've tried to check the non partitioned media. Than Advanced - filesystem utiles shows primary partition with unknown filesystem. I've tried to change it to ext4 and than entered list. The output was: Can't open filesystem. Filesystem seems damaged.

UPDATE 2: Following @heynnema's advice I've managed to recover something but I still don't know exactly what. All the files and directories are in one directory lost+found with wired names (starting by # and after different numbers). Some of files has name of a file that I had in my computer but the name doesn't match with the content. To open the folder lost+found I have to use sudo and I'm not able to copy it:

root@maria-Vostro-3360:/media/maria/9db3c007-4387-4ea8-a61c-b12fa10049bc/lost+found/#3670019# cp -i /media/maria/9db3c007-4387-4ea8-a61c-b12fa10049bc/lost+found/#4718697/ /home/maria/Desktop/odzysk/1
cp: omitting directory '/media/maria/9db3c007-4387-4ea8-a61c-b12fa10049bc/lost+found/#4718697/'

The .odt file after opening it looks like this:this It was loading very long and finally I got the message that it contains some invalid characters. While I was trying to change the encoding, the file closed due to some error.

19
  • 1
    Please try to analyze it with R-Linux and report if it gives any result. Oct 26, 2016 at 22:05
  • 1
    Maria, hi, it's Al again. I hadn't suggested fsck before because I didn't think it would even run, but it looks like it might, so... sudo fsck -f /dev/sdb1 and run it multiple times if errors still occur. Say yes to everything. Nothing to loose at this point. Cheers, Al
    – heynnema
    Oct 27, 2016 at 1:12
  • ps: this is an external USB disk, yes? After you backed up your files, did you properly dismount the drive before unplugging the USB cable? If forgot if we discussed this earlier. Cheers, Al
    – heynnema
    Oct 27, 2016 at 1:15
  • @heynnema Hello, Al :) Thanks again. Today my friend took the disk to try if he manage to do something, if not, he will return it to me in the evening. I've send him your comment. For dismouting the drive - I'm pretty sure I did, I mean I do it always. The previous system was installed on separated partition which got overfull so the system started freezing and blocking (like you can't do anything) - maybe something like that happened after I backed up the data? I don't remember for sure to be honest.
    – maria
    Oct 27, 2016 at 8:18
  • @heynnema I've managed to recover something. The details are under 2nd update. Could you please convert your comment into the reply, so I can accept it?
    – maria
    Oct 28, 2016 at 13:33

1 Answer 1

1

After an extended conversation in the comments and in chat... and just to close this question... here's what we did...

  1. performed an fsck on the external hard disk drive
  2. all the recovered files ended up in the lost+found folder
  3. we changed the name and the ownership of the folder and its files
  4. copied the folder from the external hard disk drive to the desktop
  5. reviewed a few of the files and found the missing data
2
  • It was a lucky case then. Performing a fsck on a drive where you want to recover stuff is generally a terrible idea. All's well that ends well. Nov 17, 2016 at 12:17
  • @AndreaLazzarotto I agree, but it was a last ditch effort, after testdisk was not able to help via remote control. It was a pretty messed up file system, occurring on the cusp of having to rebuild the OS, for a different reason.
    – heynnema
    Nov 17, 2016 at 15:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.