3

I am running Xubuntu 16.04 LTS. I tried another app switcher (Skippy-XD). In order for that to work, I reassigned Alt + Tab to launch Skippy-XD instead of the default xfce4 app switcher. I did not like skippy-xd however, so I uninstalled it. Now Alt Tab doesn't do anything. Restoring the default hotkeys in the Settings Manager does not solve the problem.

How do I bind Alt Tab to launch the xfce4 app switcher again?

3

Easier method: Settings Manager > Window Manager > Keyboard tab. Change the "Cycle Windows" shortcut to Alt-Tab by either double-clicking on the entry or pressing the "Edit" key. When you do either, you will be prompted with a dialog box to press the keyboard combination - press "Alt+Tab".

  • this is the proper Xfce answer – user47206 Nov 28 '17 at 14:47
0

Try xbindkeys. You can read more about it in a question here:

How can I change what keys on my keyboard do

This worked for me to override a key binding that I didn't like on ubuntu. There are also many more options for key-binding modification in that post, so consider those solutions as well.

  • That allows me to bind commands to keys, but what is the command that launches the app switcher? I've been trying to find out, without success so far. – Jim Daniël Teunis Oct 26 '16 at 12:49
0

I found the solution.

Open ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml

Look for the lines that have to do with Alt Tab, there should be two, make sure the first one looks like this:

<property name="<Alt>Tab" type="empty"> 

And the second one like this:

<property name="<Alt>Tab" type="string" value="cycle_windows_key"/>

Save the file and log off and back in.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.