1

This question already has an answer here:

After my motherboard has been changed, the system does not start any more. I think I will have to re-install, but in this case, I am affraid that the encrypted dir will not mount at login any more (will it?)

So, I am trying to first recover my home, using a live distribution. I have tried to follow advices from StackExchange and elsewhere (e.g. here) but:

sudo ecryptfs-recover-private

only says:

INFO: Searching for encrypted private directories (this might take a while)...
find: ‘/run/user/999/gvfs’: Permission denied
find: File system loop detected; ‘/sys/kernel/debug/pinctrl’ is part of the same file system loop as ‘/sys/kernel/debug’.

So I tried to give the directory path:

sudo ecryptfs-recover-private '/media/ubuntu-gnome/<UUID>/username'

After entering the passphrase, I obtained a 'success' message, saying the decrypted directory was mounted in '/tmp/ecryptfs.SOMETHING' but this directory contained:

Access-Your-Private-Data.desktop
README.txt
.ecryptfs
.Private

I guess this means it is not recovered. Then, trying again the same command resulted in failure with:

mount: mount(2) failed: No such file or directory
ERROR: Failed to mount private data at [/tmp/ecryptfs.SOMETHINGELSE].

OK, maybe I made a mistake in the passphrase, but I tried several times...

Additional information: my home is at the root of a disk having one partition, the system is on another disk. Exploring the data disk with nautilus shows:

<UUID>
 +-- username
       +-- Access-Your-Private-Data.desktop
       +-- README.txt
       +-- .ecryptfs
       +-- .Private
 +-- .ecryptfs
       +-- username
             +-- .ecryptfs
                   +-- auto-mount
                   +-- auto-umount
                   +-- Private.mnt
                   +-- Private.sig
                   +-- wrapped-passphrase
                   +-- .wrapped-passphrase.recorded
             +-- .Private

In particular, I am surprised to find:

/media/ubuntu-gnome/<UUID>/.ecryptfs/username/.ecryptfs

Is this a normal structure?

EDIT The answer was just a couple of pages away:

see the answer by @rausch the life saver to Trying to mount old encrypted home

And, by the way, my directory structure was normal.

marked as duplicate by Andrea Lazzarotto, David Foerster, Elder Geek, Kevin Bowen, TheWanderer Oct 27 '16 at 22:02

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.