3

I thought installing would be easy, but Im facing dependencies problem :

   Virtualbox-5.1 : Depends: libpng16-16 (>= 1.6.2-1) but it is not going to be installed
                    Depends: libqt5core5a (>= 5.6.0~beta) but 5.5.1+dfsg-16ubuntu7.1 is to be installed
                    Depends: libqt5widgets5 (>= 5.6.0~beta) but 5.5.1+dfsg-16ubuntu7.1 is to be installed
                    Depends: libqt5x11extras5 (>= 5.6.0) but 5.5.1-3build1 is to be installed
                    Depends: libsdl1.2debian (>= 1.2.11) but it is not going to be installed
                    Recommends: libsdl-ttf2.0-0 but it is not going to be installed
  • 1
    Dont install virtualbox like that. Try the accepted answer from here askubuntu.com/questions/633639/… and let the system handle dependencies. It is better at this than you or me. – Bruni Oct 26 '16 at 8:31
3

For Ubuntu 16.04 in your /etc/apt/sources.list: replace

deb http://download.virtualbox.org/virtualbox/debian yakkety contrib

by

deb http://download.virtualbox.org/virtualbox/debian xenial contrib
| improve this answer | |
1

Adding an Yakkety repository solved a VirtualBox 5.1 dependencies issue on Ubuntu 16.04 for me:

deb http://cz.archive.ubuntu.com/ubuntu yakkety main universe

I’ve stumbled upon same issue even so I followed Oracle’s instructions on how to add their repository for the Ubuntu 16.04 ("Xenial") as was described on the official download page https://www.virtualbox.org/wiki/Linux_Downloads page.

It seems like virtualbox-5.1 package actually packed for the Ubuntu 16.10 as it depends on some QT5 dependencies like libqt5x11extras5 (>= 5.6.0) that are not available until Ubuntu 16.10.

I’ve lurked for a repository that can satisfy these dependencies and found here: http://packages.ubuntu.com/yakkety/amd64/libqt5x11extras5/download

P.S.

If you don’t know how to add this repository, here is a help for you: https://help.ubuntu.com/community/Repositories/Ubuntu#Adding_Extra_Repositories

And you’ll probably would like to disable it just after Virtualbox 5.1 installation to avoid upgrading most of your system.

| improve this answer | |
0

Have you tried installing mentioned missing packages? If you don't, you might want to give it a try :

sudo apt-get install libpng16-16 libqt5core5a libqt5widgets5 libsdl1.2debian libqt5x11extras5 libsdl-ttf2.0-0
| improve this answer | |
  • 2
    While this may answer the question perfectly well, one disadvantage of explicitly installing packages like this is that they will not be removed when the OP decides to remove Virtualbox. Neither will they appear on the autoremove list. So they'll stay around forever. – Jos Oct 26 '16 at 8:00
  • @Jos That's scary. – Liso Dec 22 '19 at 13:50
0

Depending on how bleeding egde You want to be, Ubuntu has a 5.0 Virtual box in its repositories.

sudo apt-get install virtualbox

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.