1

I am using Ubuntu 14.04 and I installed Notepad++ using wine it successfully installed. Now I want to type Telugu text using Telugu (KaGaPa phonetic). I changed Encoding in UTF-8 but it's not showing Telugu text - it's showing boxes. What to do to display Telugu text?

  • How were you typing in KaGaPa phonetic. Is it in Ubuntu or Windows? – Anwar Oct 26 '16 at 5:58
  • It is in Ubuntu – Rindhu Kondaparthy Oct 26 '16 at 5:59
  • How can I add Telegu phonetic in Ubuntu? – Anwar Oct 26 '16 at 6:08
  • Have you ever written Telegu text in Notepad++ in Windows? – Anwar Oct 26 '16 at 6:19
2

I was able to view Telugu on NPP in WINE.

You first need to configure the font used to display the text. You can change the font by

  1. Going to Menu -> Settings -> Style Configurator
  2. Change the font there.

I change the font for Global Style and enforced this global style for all source types by using Enable Global Font option. Use an unicode font with Telugu support. You can use Noto Sans Telugu, but in my system that made the English text unreadable. So, I used Giduga font, which can display both English and Telugu scripts. You can download the fonts from this site http://fonts.siliconandhra.org/ (It's the first link)

Check this question for help installing font - How do I install fonts?

Once you changed the font, you can write Telugu in Notepad++.

Here is a screen-shot of Telugu in NPP. (Forgive me if that magically appears to be a bad word. I typed that one totally random)

telugu in npp

0
  1. Open System Settings.

  2. Click the third option called Language Support.

  3. It will open a new window. Go to the Install/Remove Languages... option.

  4. Select the language which you want to install and click the Apply button.

  5. Go to System Settings again and select Text Entry.

  6. In the Text Entry window you can find +/- symbol to add. Select Telugu font and click Add.

  7. Restart the system to start using the new font.

  • I selected Telugu language but it is not working in Notepad++. Other than Notepad++ all languages are working in Ubuntu. In Notepad ++ only English language working and if we press Enter button it is showing as CR LF – Rindhu Kondaparthy Oct 26 '16 at 7:34
  • press shift + windows(super) +space-bar key to change language mode. – Naresh S Nash Oct 26 '16 at 7:42
  • click on right most top , you find En symbol to change language mode . select Telugu . – Naresh S Nash Oct 26 '16 at 7:46
0

Install Telugu font easily by issuing this command in terminal. Use anyone of the below commands

$ sudo apt-get install language-pack-te language-pack-te-base

or

$ sudo apt-get install ttf-telugu-fonts

or

$ sudo apt-get install ttf-telugu-fonts ttf-indic-fonts language-pack-te
  • You can edit your answer to add this to the existing answer. Because this is not solely. – Anwar Oct 26 '16 at 7:58
  • The package ttf-telugu-fonts is not present in the Ubuntu archive for 16.04+. The new package name is fonts-telu. – Gunnar Hjalmarsson Oct 26 '16 at 10:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.