42

Wine is saying that Mono package is not installed, but I installed it with Terminal by:

sudo apt-get install mono-complete

What should I do?

3
  • 2
    Wine needs the Windows build of Mono, which I think you can install using winetricks. I'm a bit hazy on the specifics -- maybe someone else can take this clue and flesh out a step-by-step answer. Oct 26 '16 at 2:53
  • yeah I need a step-by-step answer, thanks anyway
    – Steve
    Oct 26 '16 at 2:56
  • 4
    Try looking at the official docs ... https://wiki.winehq.org/Mono
    – GrannySez
    Oct 26 '16 at 3:51
46

Do the following to install wine-mono:

  1. Download wine-mono.msi from the official WineHQ site.
  2. Type wine64 uninstaller.
  3. Press install from the uninstaller GUI and select the downloaded .msi package.
  4. Done!
2
  • 55
    "Press install from the uninstaller" how intuitive May 1 '19 at 23:42
  • With $USER, get "There is no Windows program configured to open this type of file". From $ROOT, it does see mono runtimes (I did reload because I didnt see a response). wine KeePass.exe still not working, even with sudo. And after trying the other answers. "Wine Mono is not installed"
    – alchemy
    Apr 17 '20 at 23:28
34

Installing .NET instead should work as well. For example by the following commands in a terminal:

sudo apt-get install winetricks
winetricks dotnet45
3
  • I don't think it worked; nothing showed up in wine uninstaller after above.
    – stucash
    Apr 26 '19 at 17:07
  • didnt work for me either. didnt try rebooting.
    – alchemy
    Apr 17 '20 at 23:19
  • I do not want to install wine-mono b/c of the wine howto here keepass2_wine But the howto does not work b/c of error: (base) leder@home-ryzen-desktop:~/Keepass2_portable$ wine KeePass.exe 0009:err:mscoree:CLRRuntimeInfo_GetRuntimeHost Wine Mono is not installed
    – Leder
    Feb 14 at 5:03
1

Other answers were not working for me on 18.04 LTS with winehq-stable package.

The workaround I found was to recreate wine32 and wine64 prefixes and install wine-mono on that with the automatic prompt.


    # Create dir for 32 bit prefix
    mkdir ~/.wine32
    # destroy default configuration (64 bit prefix)
    rm -rf ~/.wine 

    # Initial setup (create prefixes)
    WINEPREFIX="$HOME/.wine32" WINEARCH=win32 wine wineboot
    WINEPREFIX="$HOME/.wine" WINEARCH=win64 wine64 wineboot

    # To install dotnet35 on 32-bit prefix
    WINEPREFIX="$HOME/.wine32" WINEARCH=win32 winetricks dotnet35

0

You can easily download and configure with Synaptic Package Manager :

  • open Synaptic and search for msitools
  • mark for installation and click apply.
1
  • 1
    nope, apt search mistools && sudo apt install !$ installed but still cant run KeePass
    – alchemy
    Apr 17 '20 at 23:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.