6

I need to sync my iPod Touch (6th Gen) on a Windows 7 guest using VirtualBox on a Kubuntu machine. In this process, the iPod is not getting detected on the Windows host.

I have installed the guest additions on the guest OS and moreover, the iPod is detected on my Kubuntu machine (as 5th Gen!).

Bus 003 Device 006: ID 05ac:12aa Apple, Inc. iPod Touch 5.Gen [A1421]

When I was using Ubuntu, this issue did not occur and iPod got detected on the virtual machine without any configuration.

Is this a problem with KDE Plasma? Is it possible to perform the sync?

Here some of the details about system:

OS: Kubuntu 16.04 (64-bit)
Kernel Version: 4.4.0-45
KDE Plasma Version: 5.6.5

I have tried many VirtualBox versions:

Version 5.1.8-111374 with Extension Pack of the same version
Version 5.0.28-111378 with Extension Pack of the same version
Version 5.0.24-108355 (downloaded from Discover) with Extension Pack of the same version
  • Kubuntu version? Virtualbox version? Guestaddons version? – Rostislav Kandilarov Nov 1 '16 at 17:38
  • You probably have selected USB 2.0 (EHCI) controller after installing guestaddons ? It is a guess as I don't know what protocol iPod Touch is using for the sync. You can also add the specific device to the usb device list on that host machine. – Rostislav Kandilarov Nov 1 '16 at 18:11
  • I have tried with both the USB 2 and USB 3 controller, too! – skrtbhtngr Nov 1 '16 at 18:12
  • Do you see the iPod in the usb list if you try the add icon (with the green plus) in "Filter for USB devices" under USB ? – Rostislav Kandilarov Nov 1 '16 at 18:14
  • "no devices available", it shows. – skrtbhtngr Nov 1 '16 at 18:16
3

I am answering my own question as I have found the solution to this particular problem.

After some help from Rostislav, I discovered that none of my USB devices were being recognized in the VirtualBox itself!

  • The Extension Pack was installed.
  • The Guest Additions were installed in the Windows 7 guest machine.
  • I had selected USB 2.0 as the controller in Settings.

I just needed to run sudo adduser YOURUSERNAME vboxusers (and then logout and login again)! The installation process of VirtualBox did not do this automatically. This answer helped me solve this issue.

If anyone else is having the same problem, you can check if you are a member of the vboxusers group or not.

cat /etc/group | grep vboxusers

I hope this helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.