1

Here is the story:

From a fresh install of ubuntu I use a serial to usb device. screen /dev/ttyUSB0 everything goes fine and I can interact with the device perfectly.

Then I unplug this device, plug another one (a 3g modem). Again screen /dev/ttyUSB0 and everything is fine.

But then, I plug again the first device and do the screen /dev/ttyUSB0 and everything got scrambled !

I am supposing that for whatever reason the tty parameters changed. Is there a way that ubuntu (or screen) store it somewhere ? How can I get back to the initial settings ?

So far I tried:

  • rebooting
  • stty sane
  • Have you tried running stty sane or somesuch between devices? – steeldriver Oct 25 '16 at 20:34
0

Found it.

Two screen instance were actually reading /dev/ttyUSB0

Removing them all solved the issue.

Now, I am looking for solution to prevent me to do this mistake again: https://serverfault.com/questions/811474/how-to-prevent-screen-to-open-the-same-serial-device-twice

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.