4

So I just installed the latest Chrome in my new Ubuntu 16.10 installation. But I just checked the "additional software" source list but I couldn't find the entry for Google Chrome that it normally creates. So at this point, Google Chrome won't be auto-updated.

Is there someone who can give me the correct source list entry for the stable channel of Google Chrome? Or what can I do to make the Google deb add it automatically again?

Thanks!

  • Do you have this file /etc/default/google-chrome – user.dz Oct 25 '16 at 21:39
  • 1
    Yup, it's there.. but it's not in my apt list – Gladen Oct 26 '16 at 11:38
9

From Google chrome download page:

Note: Installing Google Chrome will add the Google repository so your system will automatically keep Google Chrome up to date. If you don’t want Google's repository, do “sudo touch /etc/default/google-chrome” before installing the package.

So to fix it:

  1. Remove that file

    sudo rm /etc/default/google-chrome
    
  2. Reconfigure chrome package to add repository

    sudo dpkg-reconfigure google-chrome-stable
    

    Check using grep -r google /etc/apt/sources.list.d/, no output then reinstall it.

    sudo dpkg -r google-chrome-stable
    sudo dpkg -i google-chrome-stable_current_*.deb
    

Otherwise add it manually

64bit:

echo "deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main" | sudo tee /etc/apt/sources.list.d/google-chrome.list

32bit:

echo "deb [arch=i386] http://dl.google.com/linux/chrome/deb/ stable main" | sudo tee /etc/apt/sources.list.d/google-chrome.list    
|improve this answer|||||
  • Thanks for the answer! But that didn't seem to work :( When I open "software & updates" and look in the "additional software" tab it still isn't listed there. – Gladen Oct 26 '16 at 12:41
  • @Gladen, Check grep -r google /etc/apt/sources.list.d/ , not in addition software tab but should be in other software tab. – user.dz Oct 26 '16 at 12:50
  • Nope, also doesn't return anything :( Sorry, I am translating it from Dutch so the names I wrote may not be like they are in English :p – Gladen Oct 26 '16 at 13:03
  • @Gladen, updated my answer – user.dz Oct 26 '16 at 18:51
  • I used the manual method and that seems to work for now.. looks like the deb is bugged in some way or something.. At least thanks for all the support! :) – Gladen Oct 27 '16 at 11:21
1

The bug report for this can be found at https://bugs.chromium.org/p/chromium/issues/detail?id=663069 and the cause is:

In prior versions of Ubuntu/Debian the Dir::Etc apt-config variable contained a trailing slash by default. The cronjob at /etc/cron.daily/google-chrome was concatenating that variable into a path, assuming the trailing slash. But in Ubuntu 16.10, the trailing slash is gone. That breaks the path to the list file, and the cronjob fails to fix it.

This bug has been fixed since November 8. To fix the problem, you can simply download Google Chrome again from https://www.google.com/chrome/browser/desktop/index.html and reinstall it using dpkg. In my case, since I am using Google Chrome on the dev channel, I run:

sudo dpkg -i google-chrome-unstable_current_amd64.deb
|improve this answer|||||
0

Google Chrome fails to install entry in /sources.list.d/ after install / upgrade to 16.10.

SEE: https://bugs.chromium.org/p/chromium/issues/detail?id=660145

AND: https://github.com/keybase/client/commit/7894c1f57f3ca5ecb3b5fc87e4496769103b7fd4

for possible * WORK-AROUNDS * till fixed by upstream.

|improve this answer|||||
  • 1
    please could you add any suitable tested workarounds to your answer? – Zanna Nov 10 '16 at 15:01
  • @Zanna The workaround that worked for me was to just add the right item manually. See the accepted answer for details. – Gladen Nov 23 '16 at 11:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.