3

Has anyone succeeded installing open-source mesa driver for RX 480 in Ubuntu 16.04?

According to the Phoronix articles, the free driver should be similar or even better vs amdgpu-pro (binary blob) http://phoronix.com/scan.php?page=news_item&px=Radeon-RX-480-Drivers

Using default kernel 4.4, the card was working using software render (llvm-pipe). After installing 4.8 or 4.9 kernel from ubuntu-kernel ppa (http://kernel.ubuntu.com/~kernel-ppa/mainline/), i got kernel panic or just blank screen (not responding to anything)

I am also using Oibaf PPA https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers

I did download polaris10_mc.bin and placed it /lib/firmware/amdgpu but it didn't help https://unix.stackexchange.com/a/307603

enter image description here enter image description here

2

So the answer is, 16.04 does not have Polaris (RX 480 470 460) firmware, so it can't run.

You need to install .deb package from future release, e.g. http://packages.ubuntu.com/yakkety/all/linux-firmware/download

You also need at least kernel 4.7 http://kernel.ubuntu.com/~kernel-ppa/mainline/ and

updated Mesa; e.g. Oibaf PPA: https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers

0

Ubuntu 16.04 LTS i can only say that when i put out older amd card and put in amd rx 480 it simply works..on kernel 4.4 and on kernel 4.8 Gallium 0.4 on AMD POLARIS10 (DRM 3.3.0 / 4.8.0-30-generic, LLVM 4.0.0) I use padoka repo, but i believe it will be same with oibaf repo. Here i came as i look for comparatives between amdgpu pro and this... On other side amd page explicitly say amd gpu pro driver is supported now only on ubuntu 16.04 LTS (i read that lover then 16.04 is not supported at this time,but also that for newer is not made yet)

so simple answer is yes,not even i dont need to install noting,as gallium driver i used before just with older amd card... work out of box!

Extended renderer info (GLX_MESA_query_renderer): Vendor: X.Org (0x1002) Device: AMD POLARIS10 (DRM 3.3.0 / 4.8.0-30-generic, LLVM 4.0.0) (0x67df) Version: 13.1.0 Accelerated: yes Video memory: 8154MB Unified memory: no Preferred profile: core (0x1) Max core profile version: 4.5 Max compat profile version: 3.0 Max GLES1 profile version: 1.1 Max GLES[23] profile version: 3.1 OpenGL vendor string: X.Org OpenGL renderer string: Gallium 0.4 on AMD POLARIS10 (DRM 3.3.0 / 4.8.0-30-generic, LLVM 4.0.0) OpenGL core profile version string: 4.5 (Core Profile) Mesa 13.1.0-devel - padoka PPA

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.