2

As in the title, all of Xubuntu is now not characters, just like vertical rectangular boxes, like it cant find the right font.

I am on Xubuntu 14.04

All was normal. Until I tried to add new fonts to GIMP.. I added fonts to /usr/share/fonts/trutype and didnt see them in gimp, so I started to just copy the NEW file folders I downloaded from google fonts into some other folders. One was /home/username/.fonts and still no updates in gimp , so I rebooted to see if that made the font appear and now the entire GUI interface has no characters and everything is empty rectangular boxes. And I mean everything. File manager, applications like Gimp are all illegible. I can only open and close due to memory of the button and menu locations.

I am able to run the browser and it is fine menu and all text is legible, its just seems like the xfce GUI that is messed up. I would rather get advice from experts than play with it any further. I'm not sure how just copying files to a folder could do this.

I did also install a font viewer app yesterday but it didn't do any good and could not install fonts like I expected. but now I can not even search for it to uninstall.

Has anyone seen this before or know how to solve or where to start?

UPDATE: I was able to remove the app I added, which was font-manager using the command line and apt-get --purge font-manager. I rebooted and same boxes everywhere. I also removed the .font.conf file which was present and linking to /home/norman/.config/fontconfig/fonts.conf. Still boxes are present after reboot.

  • The first thing I would suggest, if you haven't already, is removing the ~/.fonts folder completely and reboot. – Gunnar Hjalmarsson Oct 25 '16 at 17:23
  • that did not work, same boxes. I did notice that this file exist: .fonts.conf -> /home/norman/.config/fontconfig/fonts.conf – Norman Bird Oct 25 '16 at 19:41
  • So what does that file contain? (You can safely remove the whole ~/.config/fontconfig folder, since it's user specific, and not part of the default configuration.) – Gunnar Hjalmarsson Oct 25 '16 at 20:31
  • @GunnarH I deleted this fontconfig director and still boxes after reboot. I also logged off and back on as guest and thee wee boxes, so it seems like more than the user. Again, all i did was copy like 14 font folders into like 3 places where i thought font files should go /usr/share/fonts/trutype and /home/norman/.fonts thats about it. and install and remove the app font-manager – Norman Bird Oct 25 '16 at 20:54
  • I saw somewhere someone said they had same issue and got the fonts back by removing the files from /usr/share/fonts/truetype. and it worked!!! instantly all the system files are not characters, BUT, they all look a little different, even the terminal fonts changed. So now, how do I get em back to normal?? :-) – Norman Bird Oct 25 '16 at 21:01
2

Assuming that you now have reset /usr/share/fonts to its original state, you may want to try these steps:

  1. Remove the ~/.cache/fontconfig folder.
  2. Run the command sudo fc-cache -fr (it will take a while to complete)
  3. Reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.