2

I'm having some issues with my laptop's onboard Wi-Fi running under Ubuntu 16.04 LTS. Previously it ran fine, but now it's having some issues and I'm a bit lost. The WiFi card seems to be unable to be used under the Linux environment, but is fully functional under Windows. I've added some screenshots at the end and would be grateful for any help.

The wireless card in question is a Broadcom BCM4352.

Steps taken so far:

  • Turning laptop off and on
  • Disabling and enabling the Wi-Fi card under the Additional Drivers tab
  • Testing connection with USB Wi-Fi dongle (Worked successfully)
  • Testing internal Wi-Fi card under Windows (Worked successfully)

Here are some screenshots showing where I'm at: https://imgur.com/a/5WLSV

I'd be very grateful for any help

4
  • Thats exactly how all the questions in this site should look. I wish I could help you – M. Becerra Oct 25 '16 at 18:06
  • Please edit your post to provide further information. This post askubuntu.com/questions/425155/… will tell you what will be helpful. Thank you for helping us help you! – Elder Geek Oct 25 '16 at 18:27
  • What is the exact result of this terminal command: sudo modprobe wl ? – chili555 Oct 25 '16 at 19:16
  • @chili555 Command returns: modprobe: ERROR: could not insert 'wl': Required key not available – Complete the Circuit Oct 25 '16 at 19:45