2

I upgraded from Ubuntu 14.04 to 16.04 (which appears to be the latest). There have been a number of changes that are annoying but the current worst is my inability to "make link". I have Files 3.18.5 and there no longer is a "make link" when I right click on a Folder or a File. Help...

  • Are you referring to the "make" command to "link" compiled objects? What is "Files 3.18.5" A reference to Kernel 3.18.5 or version 3.18.5 of a program you are using? Sorry I'm a bit confused here. – WinEunuuchs2Unix Oct 25 '16 at 3:40
  • 3
    @WinEunuuchs2Unix I'm pretty sure it's about the "make link" option that should be in the right click context menu when the pointer is over a file or directory icon in the file browser (nautilus) to make a symlink. (can't help myself as I can't reproduce it - I have that option in MATE 16.10) – Zanna Oct 25 '16 at 5:12
  • @Zanna Thank you! After OP responds we can ask him to edit question with Nautilus the title and/or body. Haven't used that option in Nautilus myself yet but will play with it later. – WinEunuuchs2Unix Oct 25 '16 at 10:30
  • @WinEunuuchs2Unix the tag kinda helps... MATE doesn't even use nautilus (caja instead) and I only ever open it to check out AU questions - obviously I make my links with ln -s – Zanna Oct 25 '16 at 10:32
  • @Zanna totally missed the tag blush. Ubuntu 16.04 (my vanilla version) uses Files 3.14.3 and not 3.18.5 as OP is using. As such the Make Link option is still on the right-click drop down menu. – WinEunuuchs2Unix Oct 25 '16 at 10:37
5

Apparently, the "make link" option still lies under Nautilus, just not visible.

To make use of it, just enter Nautilus Preferences > Behavior tab and mark the Link Creation option (Show action to create symbolic links).

Source: What happened to the "Create Link" feature in Nautilus in Ubuntu 16.10?

3

Using @Zanna recommendation, I have a solution that uses ln -s and will hopefully help anyone who falls into my situation

  1. Open a terminal

  2. Navigate to the file you wish to make a link for

  3. Type

    ln -s filename linkname
    
  4. Copy or Move link to desktop

    mv linkname /home/user/Desktop/
    

NOTE: I like to use cp instead of mv because it makes it easier to try again when I mess up. Also remember that long file names (containing spaces) must be placed in double quotes:

"long file name"
  • I have a feeling I just did something wrong as I can't edit the answer. I take it answers and comments are treated differently. :-( – Jeff Rockel Oct 27 '16 at 11:34
  • @DavidFoerster - I followed your link to accept the answer. I have also gone through the tutorial. While references are make to voting and accepting answers, I don't see anywhere to vote or accept a comment as the answer. I am a very confused new user. – Jeff Rockel Oct 27 '16 at 18:56
  • The low-quality review interface provides a bunch of vote-to-close reasons both for statistics and (hopefully) helpful canned comments. Your post looked a lot like the typical "thank-you" post for another answer even though it actually referred to a comment. You can't "accept" a comment like you can with an actual answer. Instead the comment author should write an answer or you should do it in his or her stead. Sorry for the confusion and the erroneous review. – David Foerster Oct 27 '16 at 19:05
  • 1
    One important note: filename above must be the full path. Otherwise the link will not know where to look for the target. So either start at the root with /home/user/ or use $HOME/ to establish the path. – Jeff Rockel Oct 31 '16 at 21:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.